Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2003
    Posts
    26

    Red face Unanswered: ASP Error generated when not logged into server

    We have a relatively simple ASP page which is talking to a SQL Server 2000 database. The web server and database server are both on a Windows 2000 box.

    The page works fine all the time there is a user logged onto the server. However when there is nobody logged into the server we get an ODBC error message. 0x80040E1 Incorrect Syntax near ":"

    The webserver is IIS 5 and the access to the web is set to anonymous logon using the iusr_... account. The database is set to SQL and Windows NT Authentication. The web page is access the database using a SQL username and password. The connection string is:

    "Driver={SQL Server};Server=fred;Database=george;uid=user;pwd+p assword"

    the error message is generated when we try and run the query against the database.

    I have checked the IIS Out-of-Process Pooled Applications is set to This User and even set this to the local administrator account for the moment.

    Please can anybody help?
    Nicky Jones

  2. #2
    Join Date
    Feb 2003
    Posts
    26

    Talking Sorted!

    Somebody from a different newsgroup spotted the problem. A different locale was being used when you are logged into the server than when you are not logged in. Adding session.lcid = 2057 (UK) forced the locale to be the same
    Nicky Jones

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •