Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2003
    Posts
    7

    Angry Unanswered: Inconsistant behavior when submitted via Web Companion

    I have a web companion form that has a check box in it. After the form is submitted via the web, I can view the record and see that the checkbox is marked. But when I run a calculation on the field, its as if it is not marked.

    The checkbox is using a value list that only has "Yes" in it. Therefore, checked = yes. I then have a script that does "If <checkbox-field> = "Yes" insert text "1" in <another-field>.

    Oddly enough, if I fill out the form within filemaker, the script inserts a 1 into the other field whenever I run the script and the checkbox is marked. What is different between the web companion and filemaker? I can't figure this out.

    Thanks all.
    --
    Chevell

  2. #2
    Join Date
    Sep 2003
    Posts
    26

    Text/Number

    Be sure each field is set correctly as text and number. This can cause an error.

    Also, if you are running a script from the web, sometimes the script will not run. FileMaker can only handle one script at a time from the web. Avoid scripts on the web.

  3. #3
    Join Date
    Sep 2003
    Posts
    7
    No, I am not running the script on the web. I am using a timed execution script within filemaker that triggers a second script that does what I am trying to do. Actually, I fixed the problem. The web was placing a carriage return after "Yes" in the field. So searches for "Yes" were going unnoticed. I simply had it search for "Yes<carriagereturn>" and it works fine. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •