Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2003
    Posts
    41

    Unanswered: HDR related problem

    I have HDR running on an IDS 7.31 on SCO Unix 5.0.5. I took a Level 0 backup of my Primary, did some transactions which were replicated to my Secondary. I then shutdown my Primary using onmode -ky. I restored my previous Level 0 backup on the Primary, started replication using onmode -d primary <sec_name> and logs were sent from Secondary to Primary.

    I finally get the following status when I execute onstat -:

    On-line(Prim)(CKPT REQ)
    Blocked: CKPT

    I tried to wait for a couple of hours, but unfortunately, it stays that way forever.

    What seems to be the problem?

    Pls help.

    Thanks!

  2. #2
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780

    Re: HDR related problem

    Originally posted by antzz
    I have HDR running on an IDS 7.31 on SCO Unix 5.0.5. I took a Level 0 backup of my Primary, did some transactions which were replicated to my Secondary. I then shutdown my Primary using onmode -ky. I restored my previous Level 0 backup on the Primary, started replication using onmode -d primary <sec_name> and logs were sent from Secondary to Primary.

    I finally get the following status when I execute onstat -:

    On-line(Prim)(CKPT REQ)
    Blocked: CKPT

    I tried to wait for a couple of hours, but unfortunately, it stays that way forever.

    What seems to be the problem?

    Pls help.

    Thanks!
    Hi,

    Restore I leave the instance in a point and in determined logical log,
    after the later logical logs became back-up or was in disc.
    There is something message in log of the Online one.

    Another possibility is to recover back-up of level 0 in both and soon
    to apply to logical logs in the Primary

    Gustavo.

  3. #3
    Join Date
    Mar 2002
    Posts
    112
    basically backup and restore occure only primary to secondary only
    if you want to complete your post, you have to promote secondary site to new primary and backup from this site to restore on the other site

  4. #4
    Join Date
    Sep 2003
    Posts
    41
    Thanks for the replies.

    I was actually trying to test if logs will be sent from Secondary to Primary. This was working because it says so in the Secondary Log. The Primary Log also indicated that it received the logs and stated that Logical recovery is complete. It's just that my Primary stayed in an inaccesible state and my apps couldn't connect to it.

    Then, I sort of realized that my scheduled Log Backups were still running during my Dbspace restore to the Primary and this gave an I/O chunk error in the Primary Log. This may have affected the status of my dbspaces which may have caused the "eternal" blocked checkpoint. I am still not so sure if this was really the reason.

    Anyway, I shutdown the Informix instance, stopped the schedule of the log backups, and did another restore again. This time the whole process worked and there was no more Blocked Checkpoints (well, it did, but only for a little while).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •