Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2003
    Location
    NJ
    Posts
    2

    imp error message

    Hello,

    I am attempting to import a dmp file from an oracle 8.1.7 release into 9.0.1.1.1 enterprise edition but when i run the imp command the following error occurs

    IMP-00002: failed to open file.dmp for read
    Import file: EXPDAT.dmp>

    i have tried running this from a command prompt and sql plus.
    the imp command reads as follows
    imp system/manager file=file.dmp log=exp.log full=y rows=y ignore=y

    i will run this in the current directory of the file.dmp.

    I am able to log into sql plus so I dont think it is a name/password issue.
    I have also tried to use the
    drop user username cascade; statement then run the import and this does not work.
    The system I am running on is a win2000 sp2 system.
    If anyone can provide any information or clues, it would be appreciated. Thank you.

  2. #2
    Join Date
    Aug 2003
    Posts
    41
    Try giving the full path for file.dmp

  3. #3
    Join Date
    Sep 2003
    Location
    NJ
    Posts
    2
    Thomas, I did specify the path. for instance I had C:\temp\filename.dmp

    any other ideas?


    Originally posted by sunilthomas98
    Try giving the full path for file.dmp

  4. #4
    Join Date
    Aug 2003
    Location
    SW Ohio
    Posts
    198

    Re: imp error message

    Originally posted by kw732
    Hello,

    imp system/manager file=file.dmp log=exp.log full=y rows=y ignore=y

    Thank you.
    Instead of doing this all on a command line try using a parameter file

    import.par:
    FILE=D:\oradump\prod\dmp\PROD_20030822_A.DMP
    FULL=Y
    IGNORE=Y
    BUFFER=3000000
    LOG=D:\BILDTEST\IMPORT.TXT
    FEEDBACK=10000
    RECALCULATE_STATISTICS = Y


    command line:

    SET ORACLE_SID=TEST

    D:\ORACLE\ORA81\BIN\IMP SYSTEM/**** PARFILE=D:\BILDTEST\IMPORT.PAR


    I find I always have problems feeding the switches in the command line. The parameter files seems to work better.
    Jim P.

    Supoorting Oracle, MSSQL7, Sybase 8, & Pervasive. Confusion Reigns

  5. #5
    Join Date
    Jul 2003
    Posts
    2,296
    i like the suggestion above.

    a quick fix for you would be to change the command directory to the directory with your .dmp file.

    so, open cmd and type: cd c:\temp\file.dmp

    type dir to verify you see the file.
    then run commandline import.


    uh, you cannot import from sql-plus. Only from commandline
    - The_Duck
    you can lead someone to something but they will never learn anything ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •