Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2003
    Posts
    2

    Unanswered: Listener issue with Oracle9i on XP-Pro

    Hi,

    Oracle Version: Oracle9i 9.0.1.1
    OS: Windows XP Professional Version 2002, SP1

    I'm having problems starting my listener.
    Below are the details of the listener log, after Oracle finished installing.

    TNSLSNR for 32-bit Windows: Version 9.0.1.1.1 - Production on 07-SEP-2003 22:41:52

    Copyright 1991, 2001, Oracle Corporation. All rights reserved.

    System parameter file is C:\oracle\ora92\network\admin\listener.ora
    Log messages written to C:\oracle\ora92\network\log\listener.log
    Trace information written to C:\oracle\ora92\network\trace\listener.trc
    Trace level is currently 0

    Started with pid=2160
    Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\.\p ipe\EXTPROC0ipc)))
    Error listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=pcp)(POR T=1521)))
    TNS-12560: TNSrotocol adapter error
    TNS-00530: Protocol adapter error
    32-bit Windows Error: 38: Filename too long
    No longer listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\.\p ipe\EXTPROC0ipc)))

    I also tried to start the listener using 'lsnrctl', but got the same error.
    I tried reconfiguring a different listener but that didn't help.
    I was trying all this on my personal laptop.
    I also tried the same on my work PC (identical config), and the installation worked fine!

    So I'm confused if this is an Oracle issue or an OS issue.
    Any help would be greatly appreciated.

    Pawan

  2. #2
    Join Date
    Sep 2003
    Posts
    2
    I finally figured out the problem. It was because of some other installed application (probably McAfee) which might have been locking some files or something of that sort. Anyway after un-installing almost everything from my laptop the listener started working!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •