Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2003
    Posts
    3

    Unanswered: Help installing InnoDB

    I am tring to InnoDB-enable MySQL (ver. 4.0.0 Alpha) on my Win2000 pro machin. But each time I restart the server I got this messege :

    mysqld-nt: unrecognized option `--innodb_data_home_dir=c:\phpdev5\mysql\ibdata'
    mysqld-nt Ver 4.0.0-alpha-nt for NT on i32


    my.cnf file looks like this :


    [client]
    #password=my_password
    port=3306
    #socket=MySQL

    # Here is entries for some specific programs
    # The following values assume you have at least 32M ram

    # The MySQL server
    [mysqld]
    port=3306
    #socket=MySQL
    skip-locking
    default-character-set=latin1
    set-variable = key_buffer=16M
    set-variable = max_allowed_packet=1M
    set-variable = thread_stack=128K
    set-variable = flush_time=1800

    # Uncomment the following rows if you move the MySQL distribution to another
    # location
    basedir = C:/phpdev5/mysql/
    datadir = C:/phpdev5/mysql/data/

    # Uncomment the following rows if you are using InnoDB tables
    # Create the directories ibdata and iblogs before to start the server.
    # If necessary, modify the size of the files

    innodb_data_file_path = ibdata1:20M:autoextend
    innodb_data_home_dir = c:\phpdev5\mysql\ibdata
    set-variable = innodb_mirrored_log_groups=1
    innodb_log_group_home_dir = c:\phpdev5\iblogs
    set-variable = innodb_log_files_in_group=3
    set-variable = innodb_log_file_size=30M
    set-variable = innodb_log_buffer_size=8M
    innodb_flush_log_at_trx_commit=1
    innodb_log_arch_dir = c:\phpdev5\iblogs
    #innodb_log_archive=0
    set-variable = innodb_buffer_pool_size=80M
    #set-variable=lower_case_table_names =0
    set-variable = innodb_additional_mem_pool_size=10M
    #set-variable = innodb_file_io_threads=4
    set-variable = innodb_lock_wait_timeout=50

    # Uncomment the following row if you are using a Max server and you don't want the
    # InnoDb tables

    #skip-innobd

    [mysqldump]
    quick
    set-variable = max_allowed_packet=16M

    [mysql]
    no-auto-rehash

    [isamchk]
    set-variable= key=16M

    [client_fltk]
    #help_file= c:\mysql\sql_client\MySQL.help
    #client_file= c:\mysql\MySQL.options
    #history_length=20
    #database = test
    #queries_root= c:\mysql\queries
    #last_database_file= c:\mysql\lastdb



    =============

    I have already created the directories :

    c:\phpdev5\mysql\ibdata
    c:\phpdev5\iblogs



    AbuAnas

  2. #2
    Join Date
    Sep 2003
    Posts
    3
    ...??

  3. #3
    Join Date
    Jan 2003
    Location
    Paris, France
    Posts
    320
    First you should use a stable version of mysql 4
    Then be sure that your version include innodb and run mysqld-max

    then you should use
    c:/phpdev5/mysql/ibdata instead of c:\phpdev5\mysql\ibdata
    Olivier Miossec
    --
    http://www.lasso-developpeur.net/
    --

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •