Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2003
    Posts
    41

    Unanswered: Provider cannot be found

    Hello,

    I use ASP and have problem with creating connection to database. I use OraOLEDB provider and when I want connection open I get this error message:"Provider cannot be found. It may not be properly installed."

    This is my connection string:
    oConn = Server.CreateObject("ADODB.Connection");
    sConn = "Provider=OraOLEDB.Oracle.1;";
    sConn += "Password="+password+";"
    sConn += "User ID="+username+";"
    sConn += "Data Source="+db.dbname+";Log Level=0";

    oConn.Open(sConn)

    I've installed driver manualy but it still doesnt work.

    Can anybody help me please!!

    Thanks, Ondrej

  2. #2
    Join Date
    Mar 2002
    Location
    Reading, UK
    Posts
    1,137
    Should it be

    sConn = "Provider=OraOLEDB.Oracle;";

    instead?

    Alan

  3. #3
    Join Date
    Jan 2003
    Posts
    41
    Hi,

    I'm sure provider string is correct... Of course I try any eventuality like
    "Provider=OraOLEDB.Oracle"
    or
    microsoft provider "Provider=MSDAORA.1" but nothings help.

    Is interesting that when I used Microsoft provider I got this err "Oracle client and networking components were not found. These components are supplied by Oracle Corporation and are part of the Oracle Version 7.3.3 or later client software installation. Provider is unable to function until these components are installed."

    But Oracle client is just istalled, provider too...

    I'm realy hopeless...

    Ondrej


    Originally posted by AlanP
    Should it be

    sConn = "Provider=OraOLEDB.Oracle;";

    instead?

    Alan

  4. #4
    Join Date
    Jan 2003
    Posts
    41
    Problem is solved I didnt set full permissions for iis user to oracle directory...

    Ondrej

    Originally posted by ohanus
    Hi,

    I'm sure provider string is correct... Of course I try any eventuality like
    "Provider=OraOLEDB.Oracle"
    or
    microsoft provider "Provider=MSDAORA.1" but nothings help.

    Is interesting that when I used Microsoft provider I got this err "Oracle client and networking components were not found. These components are supplied by Oracle Corporation and are part of the Oracle Version 7.3.3 or later client software installation. Provider is unable to function until these components are installed."

    But Oracle client is just istalled, provider too...

    I'm realy hopeless...

    Ondrej

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •