Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2003

    Unanswered: Truncate of LONG datatype on query

    Hi all,
    I'm working in LabVIEW and using some open source drivers ( that utilize Microsoft ADO to access an ORACLE db.

    Things were working great until I realized that my queries were truncating strings that were too large in a given element. The datatype is set to LONG on the ORACLE server.

    I've searched around a bit and found a few other references about this happening to people but have found no working solutions. I tried upgrading the MDAC to the latest revision, 2.8, as well as the ORACLE ODBC driver to

    Most commonly the solutions included a reference to the switch titled "Force Retrieval of Longs" in the ORACLE ODBC driver, stating that turning this switch on would correct the problem. In fact I had to enable that switch to read back the smallest of my data and now some are exceeding an apparent limit of ~100k (97.6K to be exact) as they are all truncated to that size.

    Any ideas on what to try next?


  2. #2
    Join Date
    Sep 2003

    Re: Truncate of LONG datatype on query

    Note that you have to set lock BATCH_OPTIMISTIC in case of using oracle provider.

    If you are using Oracle provider and not Microsoft provider , then a READ_ONLY lock will cause this error

  3. #3
    Join Date
    Sep 2003
    Solved the problem. I tried logging in under a different username and was able to retrieve all the data. There are multiple sets of the same tables and apparently the server-side scripting was incorrectly populating some of the tables and setting the LONG size limit to 100k.

    Thanks for the suggestion anyway rajmur

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts