Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2003
    Location
    Dallas
    Posts
    5

    Angry Unanswered: I can't not start ASP.NEt due to error in Server

    Hello out there

    Thank you in advance for reading my message. I have PC that load W2k Server, and initially this OS was set up as domain controller. I then demolized this PC to make it as a stand alone server. I then installed VS.NET and the process of installation everything seem work just fine. When I started to create web application (ASP.NET) then I receive message that state server set up error. I did some reasearch on Microsoft Website and it said that due to the weak passwork of ASPUser.
    It suggested to create the user password for machine ASPUser and modify the system root directory.
    Question: where is ASPUser machine in my PC? ( I can't find it anywhere). Is anyone having same problem?
    please give me some advises where to go from here. Thanks again for any help

    MonicaBill

  2. #2
    Join Date
    Sep 2003
    Posts
    60

    Re: I can't not start ASP.NEt due to error in Server

    Funny you should ask since I just had this problem. You're near the solution but not quite there...

    Demoting the PC nukes the permissions given to userids, including the builtin ASPNET account. THere are articles in the KB to tell you how to rstore ASPNET's capabilities.

    Youll find the ASPNET user account in the User manager applett in CtrlPanel - Either in Active Directory Users or in Computer management if you're no longer a controller. ASPUSER is something referenced in the KB is something you'd have to create yourself.

    If you promoted the machine back to Domain Controller Status you may have an added problem (because of the nature of domain user accounts). The dynamic usage of the ASPNET account doesn't work anymore and the user that ASP.Net uses run pages will have to be explicitly indicated in the machine.config. The KB article mentioning ASPUSER tells how to do this. Once you create ASPUSER go to the extra links at the bottom which take you to an article describing all the permissions that are needed by the ASPNET userid. Apply every one of those to your new ASPUSER account and give it permissions everywhere indicated. Put the new ASPUSER account in machine.config's <processModel> statement and you're done...

    I had to reboot the server too before it all worked.

  3. #3
    Join Date
    Sep 2003
    Posts
    60

    Re: I can't not start ASP.NEt due to error in Server


  4. #4
    Join Date
    Sep 2003
    Location
    Dallas
    Posts
    5

    Re: I can't not start ASP.NEt due to error in Server

    Thankyou very much Bill_Dev

    It runs now! But it is running very slow. I believed that is my PC lack of power to run .NET not because of setting properties for CustomASP account.
    Again thank very much






    Originally posted by bill_dev
    Funny you should ask since I just had this problem. You're near the solution but not quite there...

    Demoting the PC nukes the permissions given to userids, including the builtin ASPNET account. THere are articles in the KB to tell you how to rstore ASPNET's capabilities.

    Youll find the ASPNET user account in the User manager applett in CtrlPanel - Either in Active Directory Users or in Computer management if you're no longer a controller. ASPUSER is something referenced in the KB is something you'd have to create yourself.

    If you promoted the machine back to Domain Controller Status you may have an added problem (because of the nature of domain user accounts). The dynamic usage of the ASPNET account doesn't work anymore and the user that ASP.Net uses run pages will have to be explicitly indicated in the machine.config. The KB article mentioning ASPUSER tells how to do this. Once you create ASPUSER go to the extra links at the bottom which take you to an article describing all the permissions that are needed by the ASPNET userid. Apply every one of those to your new ASPUSER account and give it permissions everywhere indicated. Put the new ASPUSER account in machine.config's <processModel> statement and you're done...

    I had to reboot the server too before it all worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •