Results 1 to 15 of 15
  1. #1
    Join Date
    Jul 2003
    Location
    Hamburg, Germany
    Posts
    31

    Thumbs down Unanswered: "username And/or Password Invalid"

    Hi,

    I try to connect with my client (windows XP) to the db2-Server(Solaris).
    And if use the username and password for the "Test-Connection", I get this:

    SQL30082N Attempt to
    establish connection failed with security reason "24"
    ("USERNAME AND/OR PASSWORD INVALID"). SQLSTATE=08001

    I don't understand this message, because it exists the username and the password on serverside!!!

    Thanks in advance
    Savas

  2. #2
    Join Date
    Sep 2002
    Posts
    41
    Does you get this errors with perticular user id or all user id ? Do you get this error from all client or only on perticular client ?
    Are you able to connect to database form server ?

    Make sure your database is catalog properly on client.

  3. #3
    Join Date
    Jul 2003
    Location
    Hamburg, Germany
    Posts
    31

    Unhappy

    Hi,

    I get this errors with all user id on two clients (windows XP and Linux)
    But there's something that I don't understand:

    If I try (logged in with "db2inst1") to connect to database from server with "connect to TESTDB", everything is ok! But, if I try to connect to database explicitly with the user "connect to TESTDB user db2inst1", then he asks me for my password. But if I type my password, then I get the error message!!!!

    Thanks
    Savas

    Originally posted by kuckoo
    Does you get this errors with perticular user id or all user id ? Do you get this error from all client or only on perticular client ?
    Are you able to connect to database form server ?

    Make sure your database is catalog properly on client.
    Last edited by savas; 09-18-03 at 05:08.

  4. #4
    Join Date
    Sep 2002
    Posts
    41
    This looks like permission problem in files under your sqllib/security directory. Some files ( ie db2ckpw )under that directory required sticky bit set and somehow it's changed.

    If you have any other working instances, compare file permission of files under sqllib/security and you will find out what permissions ( most probably sticky bit ) are missing OR post output of following command and I will able to see if it's permission problem or something else.

    ls -alt sqllib/security

    Kuckoo

  5. #5
    Join Date
    Jul 2003
    Location
    Hamburg, Germany
    Posts
    31
    Kuckoo,
    that's waht I get!?

    drwxrwxr-t 15 db2inst1 db2grp1 1536 Sep 16 11:47 ..
    drwxr-xr-x 2 db2inst1 db2grp1 512 Jul 8 12:56 .
    -r-s--x--x 1 db2inst1 db2grp1 21348 Jul 8 12:56 db2aud
    -rw-r--r-- 1 db2inst1 db2grp1 4096 Jul 8 12:56 db2audit.cfg
    lrwxrwxrwx 1 root other 35 Jul 8 12:56 db2chkau -> /opt/IBM/db2/V8.1/security/db2chkau
    -r-s--x--x 1 root db2grp1 17820 Jul 8 12:56 db2ckpw
    -r-x--s--x 1 db2inst1 db2grp1 25136 Jul 8 12:56 db2flacc


    Originally posted by kuckoo
    This looks like permission problem in files under your sqllib/security directory. Some files ( ie db2ckpw )under that directory required sticky bit set and somehow it's changed.

    If you have any other working instances, compare file permission of files under sqllib/security and you will find out what permissions ( most probably sticky bit ) are missing OR post output of following command and I will able to see if it's permission problem or something else.

    ls -alt sqllib/security

    Kuckoo

  6. #6
    Join Date
    Jul 2003
    Location
    Hamburg, Germany
    Posts
    31

    need help

    I need your help sathyaram_s AND Kuckoo !!!

  7. #7
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: need help

    What version of DB2 are you on ?

    I had a similar problem at home, connecting from DB2 PE v8 on XP to DB2 ESE V8 on Redhat 8 ... I have not applied fixpacks on either of the boxes ... I have had other security problems (like logon failing for ftp etc) ... I fixed some of them yesterday but still the db2 problem seems to persist ... I'll have to investigate further when I get time....

    Does anyone know if there is a problem connecting from v8 XP Client to db2 on unix ?

    Thanks

    Sathyaram


    Originally posted by savas
    I need your help sathyaram_s AND Kuckoo !!!
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  8. #8
    Join Date
    Jul 2003
    Location
    Hamburg, Germany
    Posts
    31

    Re: need help

    Hi,

    my IBM DB2 UDB is V8.1 for Solaris!!!

    Originally posted by sathyaram_s
    What version of DB2 are you on ?

    I had a similar problem at home, connecting from DB2 PE v8 on XP to DB2 ESE V8 on Redhat 8 ... I have not applied fixpacks on either of the boxes ... I have had other security problems (like logon failing for ftp etc) ... I fixed some of them yesterday but still the db2 problem seems to persist ... I'll have to investigate further when I get time....

    Does anyone know if there is a problem connecting from v8 XP Client to db2 on unix ?

    Thanks

    Sathyaram

  9. #9
    Join Date
    Sep 2002
    Posts
    41
    I had similar problem and it was related to incorrect permission but your file permissions for secrurity directory looks fine. I think it is something related to security of db2 but don't know what.

    Are you able to connect from sun server when you specified username and password ?
    _________________________________________________
    drwxrwxr-t 15 db2inst1 db2grp1 1536 Sep 16 11:47 ..
    drwxr-xr-x 2 db2inst1 db2grp1 512 Jul 8 12:56 .
    -r-s--x--x 1 db2inst1 db2grp1 21348 Jul 8 12:56 db2aud
    -rw-r--r-- 1 db2inst1 db2grp1 4096 Jul 8 12:56 db2audit.cfg
    lrwxrwxrwx 1 root other 35 Jul 8 12:56 db2chkau -> /opt/IBM/db2/V8.1/security/db2chkau
    -r-s--x--x 1 root db2grp1 17820 Jul 8 12:56 db2ckpw
    -r-x--s--x 1 db2inst1 db2grp1 25136 Jul 8 12:56 db2flacc
    __________________________________________________

  10. #10
    Join Date
    Jul 2003
    Location
    Hamburg, Germany
    Posts
    31

    ...

    If I'm logged in solaris, and then try to connect ("connect to TESTdb user db2inst1") explicit with the user db2inst, I get the error.

    But if I logged in solaris and then try to connect ("connect to TESTdb")without an explicit user, everything is ok!

    Isn't it mysterious??????

    Ciao ciao
    Savas

    Originally posted by kuckoo
    I had similar problem and it was related to incorrect permission but your file permissions for secrurity directory looks fine. I think it is something related to security of db2 but don't know what.

    Are you able to connect from sun server when you specified username and password ?
    _________________________________________________
    drwxrwxr-t 15 db2inst1 db2grp1 1536 Sep 16 11:47 ..
    drwxr-xr-x 2 db2inst1 db2grp1 512 Jul 8 12:56 .
    -r-s--x--x 1 db2inst1 db2grp1 21348 Jul 8 12:56 db2aud
    -rw-r--r-- 1 db2inst1 db2grp1 4096 Jul 8 12:56 db2audit.cfg
    lrwxrwxrwx 1 root other 35 Jul 8 12:56 db2chkau -> /opt/IBM/db2/V8.1/security/db2chkau
    -r-s--x--x 1 root db2grp1 17820 Jul 8 12:56 db2ckpw
    -r-x--s--x 1 db2inst1 db2grp1 25136 Jul 8 12:56 db2flacc
    __________________________________________________

  11. #11
    Join Date
    Sep 2002
    Posts
    41
    Problem is related to security but no idea what is wrong.

    When did this problem start ? At anytime in the past are you able to connect when specifying username? Is this happen after you applied any fixpack ? Try to find out what did you changed for last few days.

  12. #12
    Join Date
    Jul 2003
    Location
    Austin, TX, USA
    Posts
    278
    Hi,

    I had the same problem on Aix all I did was reset the password using the Config Assistant.

    Don't know if the same applies to Solaris.

    Regards

    Nitin

  13. #13
    Join Date
    May 2002
    Location
    santa ana
    Posts
    6

    Re: "username And/or Password Invalid"

    Originally posted by savas
    Hi,

    I try to connect with my client (windows XP) to the db2-Server(Solaris).
    And if use the username and password for the "Test-Connection", I get this:

    SQL30082N Attempt to
    establish connection failed with security reason "24"
    ("USERNAME AND/OR PASSWORD INVALID"). SQLSTATE=08001

    I don't understand this message, because it exists the username and the password on serverside!!!

    Thanks in advance
    Savas
    Hi Savas,
    Make sure firewall is setup correctly.
    From your pc, do : ipconfig and see what subnet are you in and ask your network engineer to see if DB2 is being blocked?
    Here are couple steps that you can do:
    1) ipconfig to find out about what subnet are you in
    2) tracert servername
    3) netstat -an | grep port number

  14. #14
    Join Date
    Jun 2003
    Location
    Canada
    Posts
    35
    Are the following parameters where changed e.i. non-default if so they were you might want to investiigate around them.

    on the server side:


    (AUTHENTICATION) = SERVER
    (TRUST_ALLCLNTS) = YES
    (TRUST_CLNTAUTH) = CLIENT


    Hope this can lead to something ...

  15. #15
    Join Date
    Jul 2003
    Location
    Switzerland, Basle
    Posts
    10
    try the username in UPPERCASE (only the username not the password).
    i remember long long ago a problem with that. (was fixed - i thought -, is only a faint chance but give it a try).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •