Results 1 to 5 of 5

Thread: ASE 12.5 on RH9

  1. #1
    Join Date
    Sep 2003
    Posts
    13

    Red face Unanswered: ASE 12.5 on RH9

    Already know ASE 12.5 won't install on RH9. I've seen John Sader's column and have asked him for assistance. Waiting for response.

    What seems to work on RH9 (based upon previous reports) is installing
    glibc-2.3.2-71.i686.rpm
    glibc-common-2.3.2-71.i386.rpm
    glibc-devel-2.3.2-71.i386.rpm
    tzdata-2003a-2.noarch.rpm

    However these have been deprecated and replaced with
    glibc-2.3.2-82.i686.rpm
    glibc-common-2.3.2-82.i386.rpm
    glibc-devel-2.3.2-82.i386.rpm
    but glibc-common-2.3.2-82.i386.rpm conflicts with
    tzdata-2003a-2.noarch.rpm

    Does anybody know where I can get
    glibc-2.3.2-71.i686.rpm
    glibc-common-2.3.2-71.i386.rpm
    glibc-devel-2.3.2-71.i386.rpm

    Thanks,
    Chris

  2. #2
    Join Date
    Feb 2002
    Location
    Willy is on vacation
    Posts
    1,208
    Source: http://www.mbay.net/~mpeppler/Linux-ASE-FAQ.html#q1.17
    Running ASE 12.5.x on RH 9 or RH EL 3.x
    Added Aug 27 2003, thanks to Jason Froebe
    ASE 12.5.x fails to run on RH 9 and the RH EL 3.x beta because of a fix added to glibc. This fix causes the dynamic linker to revert to the i386 version of glibc in situations where the binary being run accesses _errno directly. The fix was done to ensure correct behavior for multi-threaded applications. Unfortunately ASE isn't compatible with this fix. A solution to this problem is provided below:


    We now have a solution (courtesy of Jakub Jelinek from RedHat) rather than just a workaround:
    From the Rawhide branch:

    http://ftp.redhat.com/pub/redhat/lin...86/RedHat/RPMS
    glibc-2.3.2-71.i686.rpm
    glibc-common-2.3.2-71.i386.rpm
    glibc-devel-2.3.2-71.i386.rpm
    tzdata-2003a-2.noarch.rpm


    1) ASE needs to use /lib/i686/libpthread.so.0 to run properly. The RedHat patch makes us load /lib/libpthread.so.0 instead. On a default installation of AS 2.1, the library /lib/tls/libpthread.so.0 was not installed.

    2) Only glibc < 2.3.2-31 should load /lib/libpthread.so.0 if the warning is printed.

    3) Later glibc 2.3.2-31 and higher, will correctly load the /lib/i686/libpthread.so.0.

  3. #3
    Join Date
    Sep 2003
    Posts
    13

    still looking for glibc...71

    Like I said, I know what is needed because I have read this article and many more indicating how to fix it but RH has deprecated (ie gotten rid of) the old glibc and replaced it with something that doesn't solve the problem any more. I need the old glibc...71 version and was wondering if anyone knew where I could download a copy. For anyone else reading this and considering Sybase 12.5 on RH you'll be happy to know that Sybase is releasing a patch but not until the end of Oct.
    Chris

  4. #4
    Join Date
    Mar 2001
    Location
    Lexington, KY
    Posts
    606
    If I remember correctly I was able to --nodeps and ignore it. This was on a test box so your mileage may vary, caveat lector, do not try this at home, for professionals only, etc.
    Thanks,

    Matt

  5. #5
    Join Date
    Sep 2003
    Posts
    13

    RH9 on ASE12.5 works

    Thanks Matt, it now works.

    Originally posted by MattR
    If I remember correctly I was able to --nodeps and ignore it. This was on a test box so your mileage may vary, caveat lector, do not try this at home, for professionals only, etc.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •