Results 1 to 11 of 11
  1. #1
    Join Date
    Sep 2003
    Location
    Malaysia
    Posts
    5

    Lightbulb Unanswered: SQL0952N - Process Interrupted

    Dear all,

    I always receive an error message "[DB2/NT] SQL0952 Processing was cancelled due to an interrupt. SQLSTATE=57014" when I tried to perform a DELETE command from VB.Net Application. I just perform a very simple command like "DELETE FROM Artran".

    I have DB2 version 7.2 Fixpack 10 installed on XP Professional. I connect to DB2 using Oledb Provider from Visual Studio.Net.

    I have refer this problem to IBM Technical consultant but they seems not able to solve this problem.

    Thanks

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: SQL0952N - Process Interrupted

    Your IBM Consultant would have looked at this .. In case he hasn't :

    How much data does artran have ... Does the process start at the server or does it lock wait indefinitely?


    You db2cli.ini configuration QUERYTIMEOUT INTERVAL (it sounds similar) if small will cause this problem ... Increase this and see the result ..

    Cheers

    Sathyaram
    Originally posted by chen_wan
    Dear all,

    I always receive an error message "[DB2/NT] SQL0952 Processing was cancelled due to an interrupt. SQLSTATE=57014" when I tried to perform a DELETE command from VB.Net Application. I just perform a very simple command like "DELETE FROM Artran".

    I have DB2 version 7.2 Fixpack 10 installed on XP Professional. I connect to DB2 using Oledb Provider from Visual Studio.Net.

    I have refer this problem to IBM Technical consultant but they seems not able to solve this problem.

    Thanks
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  3. #3
    Join Date
    Sep 2003
    Location
    Malaysia
    Posts
    5

    Re: SQL0952N - Process Interrupted

    Thanks Sathyaram,

    I am able to perform the Delete command by increasing the QUERYTIMEOUTINTERVAL to 500.

    I have to do the setting in all client machine. Is there any other way that I can do the setting in server and apply to all clients.



    Originally posted by sathyaram_s
    Your IBM Consultant would have looked at this .. In case he hasn't :

    How much data does artran have ... Does the process start at the server or does it lock wait indefinitely?


    You db2cli.ini configuration QUERYTIMEOUT INTERVAL (it sounds similar) if small will cause this problem ... Increase this and see the result ..

    Cheers

    Sathyaram

  4. #4
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: SQL0952N - Process Interrupted

    This is a client property and so as far as I know has to be done on the client side ...

    I'm not aware of anything that can be done on the server side to change this ..



    Cheers
    Sathyaram


    Originally posted by chen_wan
    Thanks Sathyaram,

    I am able to perform the Delete command by increasing the QUERYTIMEOUTINTERVAL to 500.

    I have to do the setting in all client machine. Is there any other way that I can do the setting in server and apply to all clients.
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  5. #5
    Join Date
    Jan 2004
    Location
    Phoenix, AZ
    Posts
    42
    Hey Sathyaram,

    I have a similar issue with one of our users. He's getting the

    ODBC Call failed. - [IBM CLI Driver][DB2/6000][SQL0952N] - Process was cancelled due to an interrupt. SQLSTATE=57014. #-952.

    We are running the 8.1.5 adm/client version. This user only uses the ODBC driver to load data in access.

    Will increasing this parameter mentioned below (QUERYTIMEOUTINTERVAL)correct the problem? When I view the .ini file, I notice the parameter does not pre-exist. Do you have to add the line to the file?

    Example of the current .ini file on the client -
    ; Comment lines start with a semi-colon.

    [tstcli1x]
    uid=userid
    pwd=password
    autocommit=0
    TableType="'TABLE','VIEW','SYSTEM TABLE'"

    [tstcli2x]
    ; Assuming dbalias2 is a database in DB2 for MVS.
    SchemaList="'OWNER1','OWNER2',CURRENT SQLID"

    [MyVeryLongDBALIASName]
    dbalias=dbalias3
    SysSchema=MYSCHEMA

    [DEVELLGN]
    DBALIAS=DEVELLGN
    DESCRIPTION=LOGAN

    [DEVEL]
    DBALIAS=DEVEL

    [DORP]
    DBALIAS=DORP

    Thanks!

  6. #6
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650
    ODBC uses CLI ... So, this parameter should help ...

    If there is no entry in the db2cli.ini file, then the default value is used (Refer the manual for the default value)

    Your db2cli.ini file may read something like :

    [DEVEL]
    DBALIAS=DEVEL
    QUERYTIMEOUTINTERVAL=500

    Cheers
    Sathyaram
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  7. #7
    Join Date
    Jan 2004
    Location
    Phoenix, AZ
    Posts
    42
    That seemed to have done the trick.

    Thank You very much, Sathyaram!

  8. #8
    Join Date
    Oct 2003
    Posts
    706
    You may need to dig a little deeper to "truly solve" an issue like this... there is still a performance/scalability problem lurking here; a bottleneck.

    Why does this query, which I presume is one that your users will need to do a lot of, taking more than the default amount of time to do? It could be because:
    • the job is really so incredibly difficult that the hardware can't get the work done in time; (not bloody likely...) or,
    • there could be a contention, a timeout, a resource-shortage ... something else which is the root cause of the problem.
    To really consider the problem to be "solved," "squashed so that it cannot reappear again, you have to find and eliminate that root-cause.

    Otherwise you're going to scale up and "run out of milliseconds." You only have 1,000 of these buggers available per-second no matter how fast or slow your hardware is. If an ordinary transaction is expiring, in test or under moderate load, then the root cause must be found and eliminated.
    "Simply increasing a timeout-interval" will only delay, not remove the problem: it will resurface, again and again, causing more and more problems each time.
    ChimneySweep(R): fast, automatic
    table repair at a click of the
    mouse! http://www.sundialservices.com

  9. #9
    Join Date
    Aug 2007
    Posts
    5

    still facing problem

    Hi,
    I am connecting a db2 mainframe database through my MSACCESS application. I have linked tables in msaccess for the db2 database. When i am clicking on the link tables they are working fine, I can see the data from db2 server. But, when i am executing a sql query, it is throwing me the same error as above. I have increased the QUERYTIMEOUTINTERVAL=32500 (earlier it was not working for 500) as mentioned above in the db2cli.ini file.

    My DB2 info is as below
    ================================================== ==========
    About DB2 Administration Tools Environment
    ================================================== ==========
    DB2 administration tools level:
    Product identifier SQL08023
    Level identifier 03040106
    Level DB2 v8.1.10.812
    Build level s050811
    PTF WR21362
    ================================================== ==========
    Java development kit (JDK):
    Level IBM Corporation 1.4.1
    ================================================== ==========

    Please help me on this.

  10. #10
    Join Date
    Sep 2007
    Location
    India
    Posts
    1

    Post

    This is because of invalid joins..
    please check the join type..
    change the join type to LEFT join from the default INNER join in your Access query..

  11. #11
    Join Date
    Jul 2010
    Posts
    1

    Query properties

    In MS Access, I was also able to resolve the issue by changing the timeout setting in the Query Properties when working in a query that received the "interrupted" message.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •