I am attempting to create and exerimental environment under W2000 which includes

Initially I had
Apache native W2000 with Perl 5.6 .

Then needed a database - I installed PostgreSQL under the latest cygwin and created a test database, inserted some data into it - no problems.
My starting Perl under cygwin was 5.6

The problem is to connect from ANY Perl using DBI with DBD-Pg. I cannot link this module into either native nor cygwin Perl.
Edmund Mergl's module asks for Perl build 805 (i.e. ver 5.8), I have upgraded build 806 but this does not work either!

What could be done ?
E.g if I would use ODBC, then generic Perl DBI would connect to that cygwin PostgreSQL ?

Thanks