Results 1 to 10 of 10
  1. #1
    Join Date
    Sep 2003
    Posts
    8

    Exclamation Unanswered: I can not use sqlplus any more

    I installed ORACLE 8.1.7 on Windows XP , it run well.
    But I meet a problem now, I can not use sqlplus any more.
    I did nothing except the following:
    under start --> control panel--> administrative tools -->services --> files --> options --->disk cleanup , I press "delete files" .
    now "the files in your profiles that store these console changes are using the following amount of disk space on this computer : 0 bytes"

    Does this occur the problem ? How to fix it ?

    Thank you very much!

  2. #2
    Join Date
    Sep 2003
    Location
    The Netherlands
    Posts
    311
    Hi,

    How do u start SQL*PLUS ? From the start menu ?
    Try it from the ORACLE_HOME\bin directory SQLPLUSW.EXE of from the command line (SQLPLUS.EXE or SQLPLUSW.EXE)

    Hope this helps. If not, please provide more info.
    Edwin van Hattem
    OCP DBA / System analyst

  3. #3
    Join Date
    Sep 2003
    Posts
    8
    When I start sqlplus from "start menu" , it gives me a error message "message file SP1<lang>.msb not found"

    But when I start sqlplus from DOS enviroment , (even under %ORACLE_HOME%\ora81\bin) , it gives me a window error " SQLPLUS.EXE has encountered a problem and needs to close. WE are sorry for this inconvenience."

  4. #4
    Join Date
    Sep 2003
    Location
    The Netherlands
    Posts
    311
    hi,

    please try to find the .msb files (they contain the error messages).
    If you do not find the files, re-install sqlpus.
    If you have multiple installations, try to set the oracle_home variable to another and try again.

    hope this helps
    Edwin van Hattem
    OCP DBA / System analyst

  5. #5
    Join Date
    Sep 2003
    Posts
    8
    Hi:

    Thanks a lot for your responding !

    I found SP1us.msb , but I do not know how to do next? Any suggestion?

  6. #6
    Join Date
    Sep 2003
    Location
    Assen, Nederland
    Posts
    55
    I think you messed up with the installation files, it's easy to invoke the cmdline or the (now soon to be deprecated) gui thru sqlplusw.exe.

    einstall sqlplus thru OUI.
    Hope that helped...
    Visit My Website : http://www.oraflame.com
    _____________________________
    Tarry Singh

    OCP DBA 8i
    Currently: SQL Server DBA 7,2000
    Oracle, PHP Programmer

  7. #7
    Join Date
    Sep 2003
    Location
    The Netherlands
    Posts
    311
    Hi,

    you have the american message file, that's right. Now please check your local nls_lang settings. It might be different from 'american_america'. In that case sqlplus tries to locate the corresponding messagefilesin that language and they cannot be found.
    Edwin van Hattem
    OCP DBA / System analyst

  8. #8
    Join Date
    Sep 2003
    Posts
    8
    I reinstalled the ORACLE 8.1.7 again , the error is still on.
    please help !!!!!!

  9. #9
    Join Date
    Sep 2003
    Posts
    8
    Hi:

    I fixed the problem after check the NLS_LANG setting.

    Thanks you guys all very much!

  10. #10
    Join Date
    Sep 2003
    Location
    Assen, Nederland
    Posts
    55

    Thumbs up

    Alright. Good that you report back
    Hope that helped...
    Visit My Website : http://www.oraflame.com
    _____________________________
    Tarry Singh

    OCP DBA 8i
    Currently: SQL Server DBA 7,2000
    Oracle, PHP Programmer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •