Results 1 to 7 of 7
  1. #1
    Join Date
    Sep 2003
    Posts
    5

    Unanswered: it takes a very very time to stop sybase services in my win2k sp4 server

    I used to have a sybase 12.0 which don't really give a lot of problems. But, recently I upgrade it to sybase 12.5. Goodness, i regretted. It took very very long for me to just stop the services.

    I just wonder anyone experience the same problem.
    Is it because it is not fine tune ?
    Any advice what I should do to increase the performance ?

    Thanks.
    lawrencetan

  2. #2
    Join Date
    Mar 2001
    Location
    Lexington, KY
    Posts
    606
    ASE 12.5 uses more memory than previous releases. ASE now allocates more memory for the dataserver, procedure cache, and named caches. If you do not increase physical and/or shared memory, the additional needed memory will be taken from the default data cache, possibly affecting performance. Use sp_helpcache to check cache sizes before and after upgrade. Adjust memory if necessary to restore the original value of the default data cache after upgrade.
    Thanks,

    Matt

  3. #3
    Join Date
    Sep 2003
    Posts
    5
    Originally posted by MattR
    ASE 12.5 uses more memory than previous releases. ASE now allocates more memory for the dataserver, procedure cache, and named caches. If you do not increase physical and/or shared memory, the additional needed memory will be taken from the default data cache, possibly affecting performance. Use sp_helpcache to check cache sizes before and after upgrade. Adjust memory if necessary to restore the original value of the default data cache after upgrade.
    Hi Matt,

    Thanks for the reply.
    I've increase my physical memory to 1GB, while my ASE 12 setting was only 40MB. But then it still took more than 45 mins to stop the services. Is there any other setting or parameters that I have to take note ?

    Thank you.

  4. #4
    Join Date
    Nov 2002
    Location
    Switzerland
    Posts
    524
    What's the size of your log-segments ?
    What's your backup startegy (are you cutting the logs ? dumping them?)
    What's the value of sp_configure "recovery interval in minutes"
    How many DB have you is this ASE ?

  5. #5
    Join Date
    Sep 2003
    Posts
    5
    The segments setting is as followings:
    28400 Data, 1600 Log, 10000 Log

    Sorry, does backup strategy affect services stop time ?

    sp_configure "recovery interval in minutes"
    default=5 memory=0 config=5 run=5.
    How does this affect the service stop time ?

    I've 2 DB in this ASE.

    Please advice.

  6. #6
    Join Date
    Feb 2002
    Location
    Willy is on vacation
    Posts
    1,208
    issue a checkpoint in all user databases and then a shutdown. Check if that helps.

    I think this behaviour is bizarre, certainly something for Sybase Support people.

  7. #7
    Join Date
    Mar 2001
    Location
    Lexington, KY
    Posts
    606
    I've seen this before when I have a lot of outstanding transactions.

    Try shutting down ASE from within ISQL -- namely issue the 'shutdown go' command and see if it says 'waiting for X transactions to complete'.

    If there is activity on the system it has to cease before the ASE can shut down.
    Thanks,

    Matt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •