Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2003
    Posts
    16

    Unanswered: Lookup field returns wrong column in report

    Im sure there is a relatively straight forward explanation for this but I am having a lot of difficulty with one of my reports. The situation is this; I have a main table that is populated with data from a lookup that references another table. The other table consists of two columns. The first column is an auto number field and the second consists of the actual data I want to populate the main table with. There is no problem making the main table populate with the information from the secondary table and when I run a Query on the main table it will pull the correct data from that field (text info). But, when I run a report on this query the value that is returned for these fields is the auto number information from the secondary table.

    Thanks in advance for any help in this matter.

  2. #2
    Join Date
    Sep 2003
    Posts
    16

    Talking found the answer

    I found the answer. It appears that in a lookup field Access will show the values from the other table but in reality the values are the primary key from the second field. So in this case the table and reports will look fine but the reports will show the primary key value. Sorry if everyone knows this already but I thought it might be helpful to other newbies like me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •