Results 1 to 3 of 3

Thread: Capture Problem

  1. #1
    Join Date
    Jun 2003
    Posts
    127

    Unanswered: Capture Problem

    Hi, Can someone help me on this?

    The replication was working ok. I noticed that capture has been failing with this message in the db2diag.log all of a sudden. I don't see any message in the control trace table, trace file, *CCP file.
    I tried increasing logbufsz parameter looking at the error. Even without any transactions in the source database, as long as capture runs, it throws this message. From the message, looks like the API which reads from log files to CD tables is failing. Not sure if reinstall is needed? Thanks for your suggestions...
    ==========================
    2003-09-25-21.49.08.757994 Instance:inst1 Node:000
    PID:54018(db2agent (ECCM)) Appid:*LOCAL.inst1.030926014859
    data_protection sqlp_AsyncLogReadAPI Probe:60 Database:ECCM

    Error: sqlcode -2650, rc 1, hflag2LsnReuse 0
    action 1, startLSN 2022 222E 2020, endLSN FFFF FFFF FFFF, logBufferSize 204800
    ==========================

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: Capture Problem

    I remember I hit on a similar problem in June when we were in FP7, though I did have some messages in CCP file ...

    The recommendation was to go to FP9 (not the usual recommendation .. Toronto said they had a re-written a part of the code)


    IY38874 is the APAR Number, if this helps

    Replication has been very stable since the time we applied fixpack 9 ...

    Any case, you should open a PMR with DB2 Support

    Cheers
    Sathyaram

    Originally posted by Kota
    Hi, Can someone help me on this?

    The replication was working ok. I noticed that capture has been failing with this message in the db2diag.log all of a sudden. I don't see any message in the control trace table, trace file, *CCP file.
    I tried increasing logbufsz parameter looking at the error. Even without any transactions in the source database, as long as capture runs, it throws this message. From the message, looks like the API which reads from log files to CD tables is failing. Not sure if reinstall is needed? Thanks for your suggestions...
    ==========================
    2003-09-25-21.49.08.757994 Instance:inst1 Node:000
    PID:54018(db2agent (ECCM)) Appid:*LOCAL.inst1.030926014859
    data_protection sqlp_AsyncLogReadAPI Probe:60 Database:ECCM

    Error: sqlcode -2650, rc 1, hflag2LsnReuse 0
    action 1, startLSN 2022 222E 2020, endLSN FFFF FFFF FFFF, logBufferSize 204800
    ==========================
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  3. #3
    Join Date
    Jun 2003
    Posts
    127
    Sathyaram Thanks. I forgot to mention. I'm at fix 9 (7.2 on AIX 5). I'll try contacting support too.

    Thnx...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •