Hi :
Please note that I want to upgrade to mysql 4.0 from mysql 3.23.
To achieve this I downloaded all the mysql 4.0 rpms from the mysql site and run those rpms.But while doing this by mistake I have not uninstalled 3.23 version and also it was running when I was installing the mysql 4.o.

Please suggest me what might have went wrong because of this.

Now when I am looking in to version of mysql it is cominng as 4.0.15 .

Please suggest what are the steps one should follow if some one wants to upgrade to 4.0.15 because on mysql site they are advising to run few scripts to change grant etc,but no where it is mentioned ho to install mysql 4.0 when alraedy 3.23 exists.