Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2003
    Posts
    4

    Unanswered: syslogs is full and cant connect with isql

    Hi everyone,

    We have a situation at our site here and dont really know how to go about. This is the message we are getting:

    00:00000:00006:2003/10/02 08:18:56.46 server Can't allocate space for object 'syslogs' in database 'master' because 'logsegment' segment is full/has no free extents. If you ran out of space in syslogs, dump the transaction log. Otherwise, use ALTER DATABASE or sp_extendsegment to increase size of the segment.

    Seems to be an error message that happens now and then (according to a quick google search). A solution that is mentioned is to use:

    dump transaction master with truncate_only go

    Unfortunately we cant connect to the database with isql because of this message:

    The transaction log in database master is almost full. Your transaction is
    being suspended until space is made available in the log.

    So we cant dump the table with isql, is there another way to do this?

    Many thanks in advance,

    Ryan

  2. #2
    Join Date
    Feb 2002
    Location
    Willy is on vacation
    Posts
    1,208
    alter database master on master = <whatever space is left on the master device>

    You should never let people run transactions in master. Normally by default all new logins have master as their default database. Users not knowingly run all their tests in master that causes the master logsegment to fillup.

  3. #3
    Join Date
    Oct 2003
    Posts
    4
    Unfortunately I cant connect to the database because whenever I use isql it says that the session is suspended due to the transaction log in database master being full.

    Is there another way to connect to the db so I can issue these commands?

  4. #4
    Join Date
    Jul 2003
    Posts
    11
    Hi,

    Try Follwing Steps :-
    1. Go to $SYBASE/install directory.
    2. Give 'showserver' command.
    3. Note down the process ID's .
    4 . Kill the server processes from kill -9 <pid> command.
    5. give 'ipcs -a' command to check whether all shared memory resources are free. ('ipcs -a should give 0 rows )
    6. If the ipcs -a shows some rows, free the resources with following command
    ipcs -m <ID>
    (in ipcs -a output CPID column indiactes os level process id )
    7. if ipcs -a gives rows give 0 rows ,then again restart the server.
    with startserver command.
    After restart, the server will redo all transactions.

    If it not works kindly let me know
    Regards
    Suraj

  5. #5
    Join Date
    Oct 2003
    Posts
    4
    Hi,

    I'm not sure whether the option above will work because last week we had to shutdown the sybase database hard and the syslogs was still full.

    On another note, I've read the Sybase Admin guide saying that the option "truncate log on chkpoint" does not work on the Master database. Is this correct?

    When I'm connected to the database via isql my plan was to use the following cmd:

    "use master on master, trunc, true"

    but now I am not sure whether this will work...Anyone who can shed some light on this one?

  6. #6
    Join Date
    Oct 2003
    Posts
    1
    Ryan,

    I'm experiencing exactly the same issue with our db.

    how did you eventually get around this problem?

    Thanks,

    Steve

  7. #7
    Join Date
    Oct 2003
    Posts
    4
    I'm am planning on re-installing the complete database because there is to my knowledge no way to hack into the master database.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •