Results 1 to 9 of 9
  1. #1
    Join Date
    Oct 2003
    Posts
    6

    Unanswered: Oracle 9i Forms Help

    Need Some Help To get started
    ------------------------------------
    Installed Oracle 9i Personal Edition on Windows XP and Oracle 9i DS Release 2. Created a test form to execute but gives the following error....

    Bad Gateway
    The following error occurred:
    A DNS lookup error occurred. The host was not found.
    Please contact the administrator
    ----------------------------------------------------------------------------
    The URL address showing is below :

    http://varun:8888/forms90/f90servlet...=NO&RENDER=YES
    ----------------------------------------------------------------------------------

    I used the default setting for Application Server URL.

    What do I need to change.

    Thanks

  2. #2
    Join Date
    Sep 2003
    Location
    The Netherlands
    Posts
    311
    hi,

    did u start the OC4J instance before runnin ghte form ?
    Or do u use an application server ?

    Greetz
    Edwin van Hattem
    OCP DBA / System analyst

  3. #3
    Join Date
    Oct 2003
    Posts
    6
    I did start the OC4J instance. The database and the forms reside on the same PC.

  4. #4
    Join Date
    Sep 2003
    Location
    The Netherlands
    Posts
    311
    hi,

    did u create the url yourself ?
    If u did, use forms builder to create it, because it is not always port 8888. i've installed it at 3 dif compu's at work, and they have 3 diff port number.
    You can check a portnumber of your installation by opening the file default-web-site.xml in a text editor. It's located at ORACLE_HOME9iDS\j2ee\oracle9ids\config
    Be sure to restart your oc4j instance after it. Als be sure not to close the dos box after starting the oc4j instance. That way u shut it down.

    Hope this helps.
    Edwin van Hattem
    OCP DBA / System analyst

  5. #5
    Join Date
    Oct 2003
    Posts
    6
    I have used the default setting of the URL. The contents of the default-web-site file is as below. Let me know what I need to edit in there.

    ---------------------------------------------------------------------------
    <?xml version="1.0" standalone='yes'?>
    <!DOCTYPE web-site PUBLIC "Oracle9iAS XML Web-site" "http://xmlns.oracle.com/ias/dtds/web-site.dtd">

    <!-- change the host name below to your own host name. Localhost will -->
    <!-- not work with clustering -->
    <!-- also add cluster-island attribute as below
    <web-site host="localhost" port="0" protocol="ajp13"
    display-name="Default Oracle 9iAS Java WebSite" cluster-island="1" >
    -->

    <web-site port="8888" protocol="http"
    display-name="Oracle9iDS instance of Oracle9iAS Containers for J2EE Web Site">
    <!-- Uncomment the following line when using clustering -->
    <!-- <frontend host="your_host_name" port="80" /> -->
    <!-- The default web-app for this site, bound to the root -->
    <default-web-app application="default" name="defaultWebApp" root="/" />
    <web-app application="forms" name="forms90web" root="/forms90" />
    <web-app application ="reports" name="web" root="/reports" />

    <!-- Access Log, where requests are logged to -->
    <access-log path="../log/default-web-access.log" />
    </web-site>
    -----------------------------------------------------------------------------

    Thanks for your response.

  6. #6
    Join Date
    Sep 2003
    Location
    The Netherlands
    Posts
    311
    hi,

    what are the gateway and DNS settings on your machine (more general your network settings)?
    Are logging on to a (bussiness) domain with a DNS server or on a standalone client ?
    Edwin van Hattem
    OCP DBA / System analyst

  7. #7
    Join Date
    Oct 2003
    Posts
    6
    hi,

    I am running the form on a standalone Windows XPclient. I am connected to the internet via DSL cable. My TCP/IP settings are as follows:

    - The IP Address and DNS server address are obtained automatically.

    Jay

  8. #8
    Join Date
    Sep 2003
    Location
    The Netherlands
    Posts
    311
    hi,

    try changing the folder yu write the fmb and fmx files to. It's now'My documents', change it to "C:\Oracle\Forms", to make sure we do not have any problems with spaces in the folder name.
    Edwin van Hattem
    OCP DBA / System analyst

  9. #9
    Join Date
    Oct 2003
    Posts
    6
    Hi,
    Tried changing the folder. Same message..

    http://varun:8888/forms90/f90servlet...=NO&RENDER=YES

    ---------------------------------------------------

    Is it got to do something with the running of forms services.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •