Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2003

    Unanswered: MySql Installation Problem. Please help!

    I have installed mysql on Windows 2000. I tried to start it using "MySqld --console" in DOS prompt, but failed. I got the follwing error message:
    InnoDB: a new database to be created! 030526 1:54:19
    InnoDB: Setting file .\ibdata1 size to 10 MB
    InnoDB: Database physically writes the file full: wait... 030526 1:54:23 InnoDB: Error: Write to file .\ibdata1 failed at offset 0 0.
    InnoDB: 8388608 bytes should have been written, only 0 were written. InnoDB: Operating system error number 1453.
    InnoDB: Look from section 13.2 at InnoDB: what the error number means.
    InnoDB: Check that your OS and file system support files of this size. InnoDB: Check also that the disk is not full or a disk quota exceeded. InnoDB: Error in creating .\ibdata1: probably out of disk space
    InnoDB: Could not open data files 030526 1:54:23 Can't init databases 030526 1:54:23 Aborting 030526 1:54:24
    InnoDB: Warning: shutting down a not properly started
    InnoDB: or created database! 030526 1:54:25
    MySql: Shutdown Complete

    I totally uninstalled the MySql, deleted the empty idata file, restarted the machine, and intalled MySql again, but still got the same error when I tried to start MySql.

    I checked the error number. It means "insufficient quota". But I had more than enough free space on that machine. I installed and started the same version of MySql (4.0.14b) on my friends machine which has the windows 2000 from the same CD. Can anybody please help me to solve this problem, thanks!

  2. #2
    Join Date
    Jan 2003
    Paris, France
    First can you post your innodb setting from your my.cnf.
    This error can occure when your are ussing quotta on a shared partition using by Mysqld
    Last edited by omiossec; 10-04-03 at 08:22.
    Olivier Miossec

  3. #3
    Join Date
    Sep 2003
    Thank you for reply, omiossec.

    I couldn't find the my.cnf file on my machine.
    I guess the startup problem may be caused by the memory of my machine, which is only 32M. I think mysql may require a bigger memory for it to start up. That is bad.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts