Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2003

    Exclamation Unanswered: Large Database Managment - errno 24 - HELP

    I'll do my best to explain and I will appreciate any and all feedback.

    I have MySQL 4.0.15 installed on Windows 2000 w/SP3 and dual P3 1.13 GHZ, 2 GB RAM, a SCSI RAID 5 (320 MB) and more than enough disk space left on 2 36GB HDs.

    On this computer, I have 3 actual databases.

    1) about 75 tables and not all that much data in it (maybe 10K total records)
    2) about 190 tables with about half having < 10 records and the others ranging in size from a few records through about 60K
    3) this is the biggie. There's about 500 tables and some of these things are huge. A few tables have over 25 million records, and there are multiple tables in the millions. Then probably around 50 have just a dozen or so records.

    Now there are around a dozen users that use this database at any given time and now we're starting to get:

    Can't find file: '.\database\table.frm' (errno:24)

    and that's something about too many open file handles, which I really don't understand becuase there is never all that many things running at a time.

    We've more or less gotten over locking each other out of tables with more efficient queries, temp tables, cleaned up data, etc, but these #24 errors are annoying and are remidied only by flushing the tables.

    Unfortunately, redoing the database is not an option, so any comments/suggestions on how to deal with the mess I've been dealt would be appreciated.

    I've attached my my.ini file
    set-variable = key_buffer=768M
    set-variable = max_allowed_packet=1M
    set-variable = table_cache=1024
    set-variable = sort_buffer=2M
    set-variable = record_buffer=2M
    set-variable = thread_cache=8
    # Try number of CPU's*2 for thread_concurrency
    set-variable = thread_concurrency=4
    set-variable = myisam_sort_buffer_size=64M
    server-id = 1
    set-variable = key_buffer=256M
    set-variable = sort_buffer=256M
    set-variable = read_buffer=2M
    set-variable = write_buffer=2M

  2. #2
    Join Date
    Oct 2003
    Denver, Colorado
    Try lowering your table_cache variable.
    The default is 64, so 1024 is quite a lot. MySQL is probably opening more files than allowed it by Windows.

  3. #3
    Join Date
    Jan 2003
    Paris, France
    Try to post a show status when the error occur

    You can use

    Reduce max_connections too (less 90)

    You can also try to use open-files-limit=
    Olivier Miossec

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts