I ran my 7.1 CD through the Program Compatibility Wizard in XP and got this message: the following archives within this Setup are corrupted:XPCOM.XPI...However when I download the Setup from the web I still am unable to execute the setup. This is also true (the downloaded program) for Mozilla 1.4.