Results 1 to 3 of 3
  1. #1
    Join Date
    Oct 2003

    Unanswered: 12.5 installation on slackware 9.0 - No devices created

    Hi guys

    I'm new to linux but have got Slackware 9.0 running, ASE12.5 downloaded and installed from the sybase site, shared memory configured ... but still not able to create the master device.

    I've read the posts but they emphasize Red Hat, as do the EBF's on the sybase site.

    Without a meaningful error message I'm clueless as how to proceed.
    Any help gratefully received.


    # /opt/sybase-12.5/ASE/bin/
    sybinit.release_directory: /opt/sybase-12.5
    sybinit.product: sqlsrv
    sqlsrv.server_name: dan
    sqlsrv.new_config: yes
    sqlsrv.do_add_server: yes
    sqlsrv.network_protocol_list: tcp
    sqlsrv.network_hostname_list: dan
    sqlsrv.network_port_list: 4100
    sqlsrv.server_page_size: USE_DEFAULT
    sqlsrv.force_buildmaster: yes
    sqlsrv.master_device_physical_name: /opt/sybase-12.5/ASE/data/master.dat
    sqlsrv.master_device_size: USE_DEFAULT
    sqlsrv.master_database_size: USE_DEFAULT
    sqlsrv.errorlog: /opt/sybase-12.5/ASE/bin/dan.log
    sqlsrv.do_upgrade: no
    sqlsrv.sybsystemprocs_device_physical_name: /opt/sybase-12.5/ASE/data/sybprocs.dat
    sqlsrv.sybsystemprocs_device_size: USE_DEFAULT
    sqlsrv.sybsystemprocs_database_size: USE_DEFAULT
    sqlsrv.sybsystemdb_device_physical_name: /opt/sybase-12.5/ASE/data/sybsysdb.dat
    sqlsrv.sybsystemdb_device_size: USE_DEFAULT
    sqlsrv.sybsystemdb_database_size: USE_DEFAULT
    sqlsrv.default_backup_server: dan_bak

    # building server ...
    sh-2.05b$ ./srvbuild -r
    20:45:59.82 kernel Checked out license ASE_DEV
    20:45:59.82 kernel Adaptive Server Enterprise Developer Edition.
    20:45:59.88 kernel Using config area from primary master device.
    20:45:59.93 kernel Warning: Using default file '/opt/sybase-12.5/dan.cfg' since a configuration file was not specified. Specify a configuration file name in the RUNSERVER file to avoid this message.
    20:46:00.03 kernel os_create_keyfile: Removed old segment /opt/sybase-12.5/dan.krg
    20:46:00.04 kernel Internal run-time model set for Linux - Native
    20:46:00.04 kernel Using 1024 file descriptors.
    20:46:00.06 kernel Adaptive Server Enterprise/ 10292 IR/P/Linux Intel/Linux 2.4.7-10smp i686/rel12501/1781/32-bit/OPT/Thu Jun 6 14:14:09 2002
    20:46:00.06 kernel Sybase, Inc. 5000 Hacienda Drive, Dublin, CA 94568, USA
    20:46:00.06 kernel Using '/opt/sybase-12.5/dan.cfg' for configuration information.
    20:46:00.06 kernel Logging ASE messages in file '/opt/sybase-12.5/ASE/bin/dan.log'.
    20:46:00.18 kernel kdcl_sess_open: connectivity library supports master/query syntax.
    20:46:00.18 kernel Directory Control Layer (DCL) using directory driver: InterfacesDriver
    20:46:00.21 kernel SSL Plus v3.0.8 security modules loaded successfully.
    20:46:00.21 kernel Network and device connection limit is 1014.
    20:46:01.79 server Number of blocks left for proc headers: 3232.
    20:46:01.87 server Proc header memory allocated 1616 pages for each per engine cache
    20:46:02.31 server Memory allocated for the default data cache cachelet 1: 8192 Kb
    20:46:02.32 server Size of the 2K memory pool: 8192 Kb
    20:46:02.32 kernel Loading [] for Async disk I/O support.
    20:46:02.33 kernel dblkIO_aio_init: mapped at 0x4258d070
    20:46:02.33 kernel dblkIO_aio_read: mapped at 0x4258da00
    20:46:02.33 kernel dblkIO_aio_write: mapped at 0x4258dd30
    20:46:02.33 kernel dblkIO_aio_suspend: mapped at 0x4258da90
    20:46:02.33 kernel dblkIO_aio_return: mapped at 0x4258da80
    20:46:02.33 kernel dblkIO_aio_error: mapped at 0x4258da80
    20:46:02.33 kernel Enabling (RT) Posix asynchronous disk I/O strategy.
    20:46:02.33 kernel Initializing virtual device 0, '/opt/sybase-12.5/ASE/data/master.dat' with dsync 'on'.
    20:46:02.33 kernel Virtual device 0 started using asynchronous i/o.
    20:46:02.33 kernel Worker Thread Manager is not enabled for use in SQL Server.
    20:46:02.34 kernel Either the config parameter 'use security services' is set to 0, or ASE does not support use of external security mechanisms on this platform. The Security Control Layer will not be initialized. No external security mechanisms will be supported.
    20:46:02.34 kernel Unix interval timer enabled for sysclk interrupts.
    20:46:02.34 kernel engine 0, os pid 2759 online
    ./srvbuild: Writing RUN_dan file...
    ./srvbuild: RUN_dan file complete.
    ./srvbuild: Starting server...
    ./srvbuild: Task failed
    ./srvbuild: Unable to boot Adaptive Server 'dan' because the master device
    (/opt/sybase-12.5/ASE/data/master.dat) does not exist.
    ./srvbuild: Server 'dan' was not created

    # the RUN_dan file ...

    # ASE page size (KB): 2048
    # Master device path: /opt/sybase-12.5/ASE/data/master.dat
    # Error log path: /opt/sybase-12.5/ASE/bin/dan.log
    # Configuration file path: /opt/sybase-12.5/ASE/dan.cfg
    # Directory for shared memory files: /opt/sybase-12.5/ASE
    # Adaptive Server name: dan
    /opt/sybase-12.5/ASE/bin/dataserver \
    -d/opt/sybase-12.5/ASE/data/master.dat \
    -e/opt/sybase-12.5/ASE/bin/dan.log \
    -c/opt/sybase-12.5/ASE/dan.cfg \
    -M/opt/sybase-12.5/ASE \
    -sdan \

    # sybase processes running ...

    sybase 2247 /opt/sybase-12.5/SYSAM/bin/lmgrd -c /opt/sybase-12.5/SYSAM/licenses/license.dat -l /opt/sybase-12.5/SYSAM/log/lmgrd.log
    sybase 2248 SYBASE -T dan 6.1 3 -c /opt/sybase-12.5/SYSAM/licenses/license.dat

    # shared memory ...
    bash-2.05b# sysctl -a | grep shm
    kernel.shmmni = 4096
    kernel.shmall = 2097152
    kernel.shmmax = 134217728

    Futhermore, I'm lost as to why svrbuild mentions a default cfg file /opt/sybase-12.5/dan.cfg only to create a RUN_dan file using /opt/sybase-12.5/ASE/dan.cfg

    Thanks and Regards


  2. #2
    Join Date
    Sep 2003

    Re: 12.5 installation on slackware 9.0 - No devices created

    Hi Phillip,

    Where exactly is it erroring out on the build ?

    Try creating a test file as sybase unix user in the directory.


  3. #3
    Join Date
    Oct 2003

    Re: 12.5 installation on slackware 9.0 - No devices created

    Originally posted by trvishi
    Hi Phillip,

    Where exactly is it erroring out on the build ?

    Try creating a test file as sybase unix user in the directory.


    I run asecfg, select locations for the master and systemprocs database devices, accept all the other defaults and click on 'build server'!

    I've always logged in as sybase, and checked that I can create files in the chosen databsase device directory.

    Still, no devices are created.

    Any other thoughts ?



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts