Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2003
    Posts
    3

    Unanswered: Newbie needs Help!

    Hi there.
    I am running my mysql database on a apache webserver (Mac OS X) and worked with it for a couple of days.
    But then yesterday, as I started my server and wanted to connect to my own message board (for wich I created a db) it said it couldn't connect to the database.
    So I was running the terminal and tried to connect with the db the way I tried it befor, by just entering

    'usr/local/bin/mysql'

    But suddnely I got the error message : ERROR 2002: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (61)

    And in the error.log :

    031006 07:51:06 mysqld started
    031006 7:51:06 Can't start server: Bind on TCP/IP port: Address already in use
    031006 7:51:06 Do you already have another mysqld server running on port: 3306 ?
    031006 7:51:06 Aborting

    031006 7:51:06 /usr/local/mysql/bin/mysqld: Shutdown Complete

    031006 07:51:06 mysqld ended

    So it lookes like there is already a server or a db running???
    I don't understand?
    How can I connect to the existing db, or reactivate it?
    What did I do wrong?

    As I mentioned before I am new to this and havn't much knowledge.

    Thx in advance

    @lex
    Last edited by @lex; 10-07-03 at 05:20.

  2. #2
    Join Date
    Jan 2003
    Location
    Paris, France
    Posts
    320
    Are you sure that MySql did not start with the system ?
    Check if mysql with ps -ax to see if any mysqld is running
    Olivier Miossec
    --
    http://www.lasso-developpeur.net/
    --

  3. #3
    Join Date
    Oct 2003
    Posts
    3
    Originally posted by omiossec
    Are you sure that MySql did not start with the system ?
    Check if mysql with ps -ax to see if any mysqld is running
    Thx for answering...
    I've checked this out before, but didn't see anything that looked liked mysql (I was looking for the path or just the word 'mysql').
    I've just put there ps -ax again and here it is...maybe you can help me with that a little bit :

    1 ?? Ss 0:00.01 /sbin/init
    2 ?? Ss 0:00.04 /sbin/mach_init
    51 ?? Ss 0:01.58 kextd
    74 ?? Ss 0:00.00 update
    78 ?? Ss 0:00.00 dynamic_pager -H 40000000 -L 160000000 -S 80000000 -F /private/var/vm/swapfile
    108 ?? Ss 0:01.00 configd
    130 ?? Ss 0:00.22 /System/Library/CoreServices/SecurityServer -X
    136 ?? SNs 0:27.92 /usr/libexec/fix_prebinding
    137 ?? S 0:00.03 /Library/OpenBase/bin/openexec
    140 ?? Ss 0:00.06 /Library/OpenBase/bin/openinfo
    176 ?? S 0:00.05 /Library/OpenBase/bin/openmonitor
    180 ?? Ss 0:02.84 /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ATS.framework/Versions/A/Support/ATSServer
    239 ?? Ss 0:15.40 /System/Library/CoreServices/WindowServer -daemon
    242 ?? Ss 0:00.06 syslogd
    245 ?? Ss 0:00.04 /usr/sbin/mDNSResponder
    248 ?? Ss 0:00.40 netinfod -s local
    265 ?? S 0:00.00 /Library/OpenBase/bin/OpenBaseODBCServer
    271 ?? Ss 0:00.36 /sbin/autodiskmount -va
    287 ?? Ss 0:00.00 /usr/libexec/crashreporterd
    302 ?? Ss 0:00.00 /Library/Application Support/Norton Solutions Support/Norton Utilities/DTDaemon
    327 ?? Ss 0:00.08 /usr/local/sbin/dnsupdate daemon
    332 ?? Ss 0:00.71 /System/Library/CoreServices/coreservicesd -preload AEServer
    339 ?? S 0:00.00 nfsiod -n 4
    340 ?? S 0:00.00 nfsiod -n 4
    341 ?? S 0:00.00 nfsiod -n 4
    342 ?? S 0:00.00 nfsiod -n 4
    352 ?? Ss 0:00.03 /usr/sbin/automount -f -m /Network/Servers -fstab -m /automount -static
    354 ?? S 0:00.04 /usr/sbin/swampd
    372 ?? Ss 0:00.01 ntpd -f /var/run/ntp.drift -p /var/run/ntpd.pid
    389 ?? Ss 0:00.82 /usr/sbin/cupsd
    391 ?? Ss 0:00.00 cron
    394 ?? Ss 0:00.00 /Library/StartupItems/NortonMissedTasks/NortonMissedTasks start
    396 ?? Ss 0:01.17 /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow console
    398 ?? Ss 0:00.01 inetd
    410 ?? Ss 0:00.01 /usr/sbin/sendmail -bd -q1h
    411 ?? S 0:00.04 /usr/sbin/sendmail -bd -q1h
    414 ?? Ss 0:00.00 /usr/sbin/sendmail -C /etc/mail/submit.cf -q1h
    432 ?? S 0:00.43 DirectoryService
    438 ?? S 0:00.66 /Library/OpenBase/bin/OpenBase EuroAccountant
    441 ?? Ss 0:01.79 /System/Library/CoreServices/pbs
    447 ?? S 0:01.82 /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock -psn_0_393217
    448 ?? S 0:00.55 /System/Library/CoreServices/SystemUIServer.app/Contents/MacOS/SystemUIServer -psn_0_524289
    449 ?? S 0:01.08 /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder -psn_0_655361
    456 ?? S 0:01.46 /Applications/iCal.app/Contents/MacOS/iCal -psn_0_1441793
    468 ?? S 0:00.06 /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/ImageCapture.framework/Versions/A/Image Capture Extension.app/Contents/MacOS/Image Capture Extension -
    481 ?? Ss 0:00.03 pppd serviceid 1 plugin /System/Library/SystemConfiguration/PPPController.bundle/Contents/PlugIns/PPPDialogs.ppp debug logfile /tmp/ppp.log plugin PPPoE.ppp device en0
    483 ?? S 0:09.05 /Applications/Mail.app/Contents/MacOS/Mail -psn_0_2228225
    496 ?? Ss 0:00.34 /usr/sbin/lookupd
    516 ?? S 0:12.97 /Applications/Safari.app/Contents/MacOS/Safari -psn_0_2359297
    517 ?? S 0:03.56 /Applications/Utilities/Terminal.app/Contents/MacOS/Terminal -psn_0_2490369
    518 std Ss 0:00.35 login -pf
    519 std S 0:00.04 -tcsh (tcsh)
    521 std R+ 0:00.00 ps -ax

    Is there something inside that code that is mysql?
    Can I just kill it?

    @lex

    PS. Maybe my failure was that I didn't disconnect from the database before I was shutting down the Web Sharing...?

  4. #4
    Join Date
    Oct 2003
    Posts
    3
    You know what I just did.
    I deleted all related mysql files in the local folder to 'uninstall' it.
    I also deleted the startupitem.
    Installed everything again and tried it...it doesn't work!
    Still the same problem...
    What could it be?

    @lex

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •