Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Join Date
    Oct 2003
    Posts
    18

    Smile Unanswered: Lytec Pervasive intermittent erors-Help!!!

    I am having frequent problems with Lytec XE multi-user that our technical support believes is due to the pervasive database manager sql 2000i. We need help! Please!

    I have windows xp pro in a wired peer to peer mode. All computers run Lytec and Soapware. One computer, the "server", has x-link and docs exchange. The other "workstations" just have Lytec and Soapware.

    We have intermittent errors. New patients that we enter into Lytec are not always being transferred into soapware by x-link. I've been told that pervasive database manager needs to recognize a new data in order to put the data in soapware. We reboot the system, modify the new patients street address slightly, then the patient is recognized and transferred. Then the error won't happen again for another couple days. Whenever I call tech support the problems spontaneously revolves and the process repeats itself.

    We also get an error that says something like, "database service manager has encountered an error and needs to close". After this we can't even use Lytec without a reboot. We saved some of the details of this error and faxed it to out tech support, but we can't get it fixed.

    I reloaded the entire operating system and software onto our "server" recently and we still have these error.

    These problems cause a lot of difficulty with our busy medical practice. Is there a pervasive patch for Lytec with XP pro; if so, how do we install it? Is there something we have set up incorrectly? Please help us with this!!!!

    Thanks :-) !!!

  2. #2
    Join Date
    Sep 2003
    Posts
    17
    From what is sounds like, my guess would be that X-Link isn't able to post changes over due to the database server being corrupted. I just read that there was some critical patch and update for both Pervasive and MySQL that was announced this week. I can't find that now however.
    Last edited by RHAVLICK; 10-10-03 at 14:32.

  3. #3
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    1

    Re: Lytec Pervasive intermittent erors-Help!!!

    You might want to think about upgrading your Lytec XE to Lytec 2004. It upgrades the database engine to Pervasive.SQL Version 8.0. According to the Lytec VAR website "With this new version of Lytec's database engine, the end result is a dramatic improvement in Lytec's speed and stability."

  4. #4
    Join Date
    Feb 2004
    Posts
    3

    Re: Lytec Pervasive intermittent erors-Help!!!

    Originally posted by rogerf
    You might want to think about upgrading your Lytec XE to Lytec 2004. It upgrades the database engine to Pervasive.SQL Version 8.0. According to the Lytec VAR website "With this new version of Lytec's database engine, the end result is a dramatic improvement in Lytec's speed and stability."
    I agree. Lytec 2004 is the most stable version of Lytec in a long time. Service pack 2 was just release. more info at:
    http://www.microwize.com

  5. #5
    Join Date
    Jan 2006
    Posts
    1
    Quote Originally Posted by dghundt
    I am having frequent problems with Lytec XE multi-user that our technical support believes is due to the pervasive database manager sql 2000i. We need help! Please!

    I have windows xp pro in a wired peer to peer mode. All computers run Lytec and Soapware. One computer, the "server", has x-link and docs exchange. The other "workstations" just have Lytec and Soapware.

    We have intermittent errors. New patients that we enter into Lytec are not always being transferred into soapware by x-link. I've been told that pervasive database manager needs to recognize a new data in order to put the data in soapware. We reboot the system, modify the new patients street address slightly, then the patient is recognized and transferred. Then the error won't happen again for another couple days. Whenever I call tech support the problems spontaneously revolves and the process repeats itself.

    We also get an error that says something like, "database service manager has encountered an error and needs to close". After this we can't even use Lytec without a reboot. We saved some of the details of this error and faxed it to out tech support, but we can't get it fixed.

    I reloaded the entire operating system and software onto our "server" recently and we still have these error.

    These problems cause a lot of difficulty with our busy medical practice. Is there a pervasive patch for Lytec with XP pro; if so, how do we install it? Is there something we have set up incorrectly? Please help us with this!!!!

    Thanks :-) !!!

    I know this is a few years later, but I was wondering if you ever fixed the error?

    I'm a programmer and have had tons of trouble with Lytec XE (version 4) and X-Link. The problem is very similar to yours. Sometimes, for no reason, X-link quits reading patient changes/creations in Lytec XE. I managed to delete a few patients, then, X-Link was reading patient changes/creations again. This can happen again within a few hours, days or weeks. It's unpredictable.
    One way to guarantee reestablishing the link is to: Close Lytec and X-Link, delete the Audit_Trails.dbp file, reopen Lytec (the file is regenerated), then any new patient creation/changes are read. This is the file that X-Link depends on for transferring patient demographics. It's almost as if this file gets corrupted in a way that X-Link cannot read it anymore. However, Lytec doesn't seem to have a problem with it.

    If you have fixed the problem, I would like to know how you did it. Thanks in advance

  6. #6
    Join Date
    Oct 2003
    Posts
    18
    I have lytec 2005 now, but I finally fixed the error in Lytec XE. Excuse my rough terminology -

    It seemed that there was a Pervasive locator file that basically told Lytec who was the database server. It noticed that this file was moving around to different clients in the office and thought this might cause a problem after reading some knowledge base articles. Here's what I did.

    I turned on my lytec server all by itself, accessed the Lytec practice, found the locator file in the data base folder (it starts with a tilde ~), then modified its property to read only starting with a right click on the file icon, then chosing properites. Back on my running network with multiple Lytec clients, the locator file never moved off the server. Once I did this single change, it was perfect from then on. I think this change basically only allowed one computer to 'hold the ball'.

    This error does not seem to occur in Pervasive for Lytec 2005.

    Crazy error, I can't figure out why many others did not have this problem! Hope this helps and sorry I didn't post my answer sooner!!!!!
    Last edited by dghundt; 04-18-06 at 17:27.

  7. #7
    Join Date
    Jun 2006
    Location
    Texas
    Posts
    4

    Lytec SOAPware

    I'm interested in talking with docs who use this combination Lytec SOAPware. I use Lytec 2005 and have been using SOAPware for about a year. I don't use close to the capability of either. I'm solo primary care - outpatient only. http://www.dbforums.com/db_images_v3...s/rolleyes.gif

  8. #8
    Join Date
    Oct 2003
    Posts
    18
    Sure...
    What would you like to talk about?

  9. #9
    Join Date
    Jun 2006
    Location
    Texas
    Posts
    4
    Are you primary care? what country?

    MD in Texas

  10. #10
    Join Date
    Oct 2003
    Posts
    18
    Internal Medicine
    Virginia

    I sent you an email if you want to use that since this thread is old.

  11. #11
    Join Date
    Jun 2006
    Location
    Texas
    Posts
    4
    I have Lytec 2004 and 2005. Employees who no longer work for me made up nonsensical diagnosis codes for use in Lytec 2004. I can't figure out how to delete them since the codes are still "attached" to a patient. Is there a way to delete stupid codes?

  12. #12
    Join Date
    Oct 2003
    Posts
    18
    As you discovered, I don't think you can delete diagnosis codes if they are curretnly linked to a patient billing item. Unlike transaction codes, you can't make diagnosis codes inactive.

    Can you edit the diagnosis codes you have? That would be the easiest.

    Otherwise, I think you would have to find every patient with the stupid diagnosis code and change it, then delete the code.

    Lytec should be able to find all references to a particular diagnosis code, if not, you could do an sql query with the pervasive database directly. Make sure you know what you are doing and back it all up first.

  13. #13
    Join Date
    Feb 2009
    Posts
    2

    Lytec XE Error code 2 - multi-user professional

    Our system froze when we were trying post daily activity in the billing field. We got a code 2 error and now only able to access patient lists and scheduling functions. Can anyone help? Thanks in advance.
    ----------------------------------------------------------------------------------

    Quote Originally Posted by dghundt
    I am having frequent problems with Lytec XE multi-user that our technical support believes is due to the pervasive database manager sql 2000i. We need help! Please!

    I have windows xp pro in a wired peer to peer mode. All computers run Lytec and Soapware. One computer, the "server", has x-link and docs exchange. The other "workstations" just have Lytec and Soapware.

    We have intermittent errors. New patients that we enter into Lytec are not always being transferred into soapware by x-link. I've been told that pervasive database manager needs to recognize a new data in order to put the data in soapware. We reboot the system, modify the new patients street address slightly, then the patient is recognized and transferred. Then the error won't happen again for another couple days. Whenever I call tech support the problems spontaneously revolves and the process repeats itself.

    We also get an error that says something like, "database service manager has encountered an error and needs to close". After this we can't even use Lytec without a reboot. We saved some of the details of this error and faxed it to out tech support, but we can't get it fixed.

    I reloaded the entire operating system and software onto our "server" recently and we still have these error.

    These problems cause a lot of difficulty with our busy medical practice. Is there a pervasive patch for Lytec with XP pro; if so, how do we install it? Is there something we have set up incorrectly? Please help us with this!!!!

    Thanks :-) !!!

  14. #14
    Join Date
    Oct 2003
    Posts
    18
    not really a related issue, but hard to find anyone out there.

    wow, you're still using lytec xe? Really?
    Help us help you - need much more detail. Everything you can give.
    For example - what is an error 2 code?
    Operating system? trying from client or server or both?
    Did you reboot your sever? (sounds silly but sometimes it works)
    Hard drive scan show any errors? - maybe hard drive on the fritz.
    Do you have a back up just prior to the failure? It is gold now. Don't lose it. And get it off your server if that is the only place you have it. If your hard drive crashes, you may lose it forever.

    This company has a good reputation from others I have talked to about database corruption services http://www.satechs.com/services.htm

  15. #15
    Join Date
    May 2005
    Posts
    15
    If you need a Pervasive Btrieve file repaired that has error 2 you might try visiting Nelson Software Solutions DDF and Data Editor for Pervasive Btrieve. They charge a flat fee and no charge if it is not repaired.
    Thanks,
    Gil

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •