Results 1 to 3 of 3
  1. #1
    Join Date
    Oct 2003
    Posts
    2

    Unanswered: Listbox Requery error

    I have a client app that works on all the computers in my office except for one. The error occurs when I try to requery a listbox in Form2 from Form1:
    Forms!Form2!listbox.requery

    But I get the error "Method 'Requery' of object '_ListBox' failed."
    Requerying directly from Form2 (me.Listbox.Requery) works fine.

    Again, there is only one computer where the application doesn't work on. All of them are running Windows 2000 Professional, with MS Acesss 2000.

    Any ideas?

  2. #2
    Join Date
    Sep 2003
    Location
    Cincinnati, Oh USA
    Posts
    203

    Re: Listbox Requery error

    depending upon were your list is being populate from there could be a couple of causes, but I would suggest that you check the machine that fails and see if it's service pack and more importantly Access (Office)update levels are the same as the others. I've seen this happen before and the answer was in the Offuce service pack level.


    Originally posted by nat1009
    I have a client app that works on all the computers in my office except for one. The error occurs when I try to requery a listbox in Form2 from Form1:
    Forms!Form2!listbox.requery

    But I get the error "Method 'Requery' of object '_ListBox' failed."
    Requerying directly from Form2 (me.Listbox.Requery) works fine.

    Again, there is only one computer where the application doesn't work on. All of them are running Windows 2000 Professional, with MS Acesss 2000.

    Any ideas?

  3. #3
    Join Date
    Oct 2003
    Posts
    2

    Re: Listbox Requery error

    That was it. Thanks. The problem computer was running Service Pack 4 and all others were on service pack 3.

    Originally posted by RickKnight
    depending upon were your list is being populate from there could be a couple of causes, but I would suggest that you check the machine that fails and see if it's service pack and more importantly Access (Office)update levels are the same as the others. I've seen this happen before and the answer was in the Offuce service pack level.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •