Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2003
    Posts
    4

    Question Unanswered: cannot connect to remote SQL server

    Hi,

    From the SQL Enterprise Manager, i can connect to MS SQL database in server1, but not on Server2. On Server2 its giving Timeout.

    When i login into Server2 by Terminal services and open Enterprise Manager, i can connect to the database.

    What could be the reason that within the Server2, can connect to the database, but cannot connect from outside the server.

    Any ideas?

    Thanks

  2. #2
    Join Date
    Jan 2003
    Location
    New York
    Posts
    160
    any firewalls between the 2 servers ?
    both internal ips ?
    can you connect server2 to server1 ?
    Beyond Limitation

  3. #3
    Join Date
    Oct 2003
    Posts
    4
    No there are no firewalls... (i can login through Terminal services)
    And i'm connecting from my local PC to either Server through Enterprise manager.

    MS SQL Server of Server1 is giving Timeout.
    Any network settings in MS SQL server going wrong?

  4. #4
    Join Date
    Sep 2003
    Posts
    212
    Originally posted by reliableHost
    No there are no firewalls... (i can login through Terminal services)
    And i'm connecting from my local PC to either Server through Enterprise manager.

    MS SQL Server of Server1 is giving Timeout.
    Any network settings in MS SQL server going wrong?
    Two options:

    1. Add the server using the Client Network Utility under Microsoft SQL Server. Add the servername u want to use, if you have the IP address of the server add it in. Go under alias -> TCP/IP or if the server is local go alias -> Named pipes

    2. Also you could try adding the server name and the ipaddress in the hosts file under 'C:\Winnt\system32\drivers\etc\hosts'.
    For eg: 1x.xx.x.xx SERVERNAME

    just append this to the end of the host file

    Hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •