Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2003

    Unanswered: Query with 2gb tmpfile...


    I have a query that generates the error "Not enough space on temporary disc"

    -There are lots of GB in the tmp and temp directories.
    -I tried to compact and repair the database before the query was run.
    -I tried to run the query without transaction.

    The query is a simple maketable query that selects from two tables containing 164382 rows each.

    the reason seems to be the tmpfile that exceeds 2 gb. How can I get around this problem?

  2. #2
    Join Date
    Sep 2003
    Access has a 1gig limit AND a milllion record limit ... You can't.

  3. #3
    Join Date
    Jul 2003
    I had a tempfile with the size of 2 gb....

    Is the limit for a query 1 gb and the limit for the database 2gb?

    Whatever... I solved my problem, there was a join that was missing.
    Now the query works fine again. I had to bring back an old version of the database from backup and test. It worked. When I opened the query in designview I saw the join... banged my head on the table...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts