Results 1 to 3 of 3
  1. #1
    Join Date
    Oct 2003

    Unanswered: MSDE Connection Issues

    We are trying to deploy an application using the MSDE 2000 server. However we have rampant connection issues.
    It doesn't seem to matter if it is running on Windows 2000, XP, or 98. Often ODBC (or some other database tool) can see a Server in the list, but says "Server not found or connection failed" when you attempt to connect to it.

    It is not a network connection problem. We can ping and access files on the machine hosting the MSDE from 'client' machines

    This only seems to be a problem with MSDE, as our test servers running SQL 7.0 and SQL 2000 (full) don't appear to have this problem.

    We have tried installing the latest MDAC (2.7 and 2.8) occastionally that resolves the problem.

    Is there a nice Ends all Beats all solution for connectivity issues with MSDE ?

  2. #2
    Join Date
    May 2003

    Not that I'm aware of. You can ping the server, do you have a valid user defined in the server that has at least read only access to the database you are trying to read from? If you are trying to access the MSDE using NT authentication, any user in MSDE will need to be defined as a domain user or as a local NT user defined on the MSDE machine.



  3. #3
    Join Date
    Oct 2003

    I am using SQL authentication, with the SA user.
    I can log in locally to the machine.

    So when I try to connect through ODBC or something else on a machine. I specify SA and the appropriate password.

    Besides, when it is actually an authentication problem. it says "Access Denied" not
    "Server not found or doesn't exist"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts