Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2003
    Posts
    12

    Unanswered: ODBC Connection Problems

    I'm having problems connecting to an MSDE database through ODBC.
    The following message appears below:

    Connection Failed:
    SQL State: '01000'
    SQL Server Error: 10061
    [Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]
    Connection Open (Connect())
    Connection Failed:
    SQL State '08001'
    SQL Server Error 17
    [Microsoft][ODBC SQL Server Driver][TCP/IP Sockets]SQL
    Server does not exist or access denied

    I've tried the following
    1. Downloading the lastest version of MDAC.
    2. Tried Pinging the server which was successful.
    3. Setting up an ODBC connection to the server from another client which was successful.
    4. Adding an entry in my hosts file to see the server.
    5. Searching the archives for a solution.

    Does anyone have any other ideas as I stumped?

    Thanks.

  2. #2
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    Are you sure you have declared the full server (and instance) name for the MSDE instance? Check services on the MSDE box, and look for MSSQL$___. The ___ is the instance name. Also, are you able to connect to the MSDE instance with any other tools (Query Analyzer, OSQL, etc.)?

  3. #3
    Join Date
    Feb 2003
    Posts
    12
    It's quite embarrassing but someone put the wrong IP address label on the server. Thanks for your help.
    Last edited by griffen; 10-14-03 at 12:57.

  4. #4
    Join Date
    Feb 2002
    Location
    Minneapolis, MN
    Posts
    253
    As fate would have it, I am encountering a very similar problem. Everything was working fine and dandy up until two days ago when suddenly you were unable to connect to SQLServer.

    At first, you were able to connect via EM but not Query Analyzer. Now suddenly you're unable to connect using either. This literally happened overnight. I'm gettign the same error message as referenced above. I'm able to ping the box just fine, but cannot isql into it or use Query Analyzer/EM.

    I'm running SQL2K on SP3 / Windows 2000 Advanced Server.

    ANY suggestions would be greatly appreciated.

    P.S. - One of the boxes is a development box and one is a production machine. I have considered installing MDAC 8 on the dev machine to see if this does the trick. Has this worked for anyone else who was having a similar problem, and what - if any - were the side effects?

    Thanks again!
    Anthony Robinson

    "If I'm curt with you, it's because time is a factor here. I think fast, I talk fast, and I need you guys to act fast if you want to get out of this. So, pretty please - with sugar on top..."

  5. #5
    Join Date
    Feb 2002
    Location
    Minneapolis, MN
    Posts
    253
    ...also forgot to mention that I'm unable to create an ODBC connection to the servers as well.

    Thanx
    Anthony Robinson

    "If I'm curt with you, it's because time is a factor here. I think fast, I talk fast, and I need you guys to act fast if you want to get out of this. So, pretty please - with sugar on top..."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •