Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2003
    Location
    Penang, Malaysia
    Posts
    212

    Unanswered: Can't open Access Application.

    Hi , first time posting an Access question here.

    I'm not familiar with Access and very new to macros and stuff.

    Here is the case, I am trying to open a Microsoft Access Application that was written by someone else.

    I don't know what previous version of Access he was using to develop the application.

    I'm using Access 2002 with Win XP Pro.

    Each time I click a button on the Form, I get this window pop up error:

    The expression ON Click you entered as the event property setting produceed the following error: Module Not Found

    * the expression may not result in the name of macro, the name of a user-defined function , or [Event Procedure]

    * There may have been error evaluating the function ,event, or macro.

    -------------------------------------------------------------
    My friend tried it in another PC with Access XP on a Windows 98 OS.

    Please advice on how I can solve this problem. Anything regarding to compatibility of OS or Access version or tips.

    Thanks.
    Patrick Chua
    LBMS ( Learn By My Self) NPQ ( No paper Qualification )

  2. #2
    Join Date
    Nov 2002
    Location
    Belgium
    Posts
    243

    Re: Can't open Access Application.

    Originally posted by Patrick Chua
    Hi , first time posting an Access question here.

    I'm not familiar with Access and very new to macros and stuff.

    Here is the case, I am trying to open a Microsoft Access Application that was written by someone else.

    I don't know what previous version of Access he was using to develop the application.

    I'm using Access 2002 with Win XP Pro.

    Each time I click a button on the Form, I get this window pop up error:

    The expression ON Click you entered as the event property setting produceed the following error: Module Not Found

    * the expression may not result in the name of macro, the name of a user-defined function , or [Event Procedure]

    * There may have been error evaluating the function ,event, or macro.

    -------------------------------------------------------------
    My friend tried it in another PC with Access XP on a Windows 98 OS.

    Please advice on how I can solve this problem. Anything regarding to compatibility of OS or Access version or tips.

    Thanks.

    I had this one time also.
    My problem was that one of my procedure was incorrect.

    Let' s say I have a button (cmdTest) on my form.
    In my case there should be a procedure :

    Code:
    Private Sub cmdTest_Click()
    
    End Sub
    But for one reason the _Click was gone so it was :

    Code:
    Private Sub cmdTest()
    
    End Sub
    I put it back and my problem was solved.
    It also took me 2 days before I noticed.

    Check this out.

  3. #3
    Join Date
    Oct 2003
    Location
    Roanoke, Va
    Posts
    445

    Smile Re: Can't open Access Application.

    Originally posted by Patrick Chua
    Hi , first time posting an Access question here.

    I'm not familiar with Access and very new to macros and stuff.

    Here is the case, I am trying to open a Microsoft Access Application that was written by someone else.

    I don't know what previous version of Access he was using to develop the application.

    I'm using Access 2002 with Win XP Pro.

    Each time I click a button on the Form, I get this window pop up error:

    The expression ON Click you entered as the event property setting produceed the following error: Module Not Found

    * the expression may not result in the name of macro, the name of a user-defined function , or [Event Procedure]

    * There may have been error evaluating the function ,event, or macro.

    -------------------------------------------------------------
    My friend tried it in another PC with Access XP on a Windows 98 OS.

    Please advice on how I can solve this problem. Anything regarding to compatibility of OS or Access version or tips.

    Thanks.
    You might try going to the code window for one of the forms and selecting from the Debug menu, Compile. The problem may show itself.

    Gregg

  4. #4
    Join Date
    Jul 2003
    Location
    Penang, Malaysia
    Posts
    212
    Thanks for u'r replys. I try it again later.


    Does compatibility of OS has anything to do with it?
    Cause it can be open from a fren pc with office 98 vs mine with win XP profesional.
    Patrick Chua
    LBMS ( Learn By My Self) NPQ ( No paper Qualification )

  5. #5
    Join Date
    Nov 2002
    Location
    Belgium
    Posts
    243
    Originally posted by Patrick Chua
    Thanks for u'r replys. I try it again later.


    Does compatibility of OS has anything to do with it?
    Cause it can be open from a fren pc with office 98 vs mine with win XP profesional.
    I'm not sure it has something to do with the OS, but it is possible that your database will not run on every version of Access.
    For example : my database only works for Ofice XP. It gives an error while opening with Access 2000.
    But it is a different kind of error than what you got.

  6. #6
    Join Date
    Dec 2002
    Location
    Préverenges, Switzerland
    Posts
    3,740
    you might have a library problem: older versions of access (e.g. ?? your pal's w98 machine) referenced the DAO library but current versions do not refernce DAO by default.

    it's fast enough to check:

    ALT-F11 should open a code window.
    from the code window menu: Tools/References and scroll down the (ticked-then-alpha sorted) list till you get to Microsoft DAO 3.6 ...tick the box and try your button again.

    untick it again if this doesn't solve the problem.

    izy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •