Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2003
    Posts
    3

    Unanswered: Archiving of redo logs

    What would stop the process of archiving off the redo logs...

  2. #2
    Join Date
    Apr 2003
    Location
    Greenville, SC (USA)
    Posts
    1,155
    ALTER DATABASE NOARCHIVELOG;

    You must restart the database for this to take effect

    Gregg

  3. #3
    Join Date
    Oct 2003
    Posts
    3
    Originally posted by gbrabham
    ALTER DATABASE NOARCHIVELOG;

    You must restart the database for this to take effect

    Gregg
    Sorry the thread I posted might have sounded a bit confusing...basically my DB is in archivelog mode but the redo logs are growing very quickly and not arhiving them off...

  4. #4
    Join Date
    Oct 2003
    Posts
    3
    Originally posted by gbrabham
    ALTER DATABASE NOARCHIVELOG;

    You must restart the database for this to take effect

    Gregg
    Sorry the thread I posted might have sounded a bit confusing...basically my DB is in archivelog mode but the redo logs are growing very quickly and not arhiving them off...

  5. #5
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    You can issue a checkpoint by the command

    alter system switch logfile;

    I always forget if it is alter system or alter database, so be sure to check the sql documentation. This should trigger the archiving of the current log. If no archiving happens, and you are working on UNIX, you should check for the archSID process. It could be that it crashed for some reason. Hope this helps.

  6. #6
    Join Date
    Oct 2003
    Location
    Republic of Srpska, Bosnia and Herzegovina
    Posts
    35

    archiving

    If no archiving happens maybe you must set parameter log_archive_start.
    alter system set log_archive_start=true scope=spfile;
    if spfile is not created you can create it with command
    create spfile from pfile;
    or you can pass parameter value in init.ora file
    and then restart the database.
    Hope this helps.

  7. #7
    Join Date
    Sep 2002
    Location
    ITALY
    Posts
    53
    Originally posted by Hey
    Sorry the thread I posted might have sounded a bit confusing...basically my DB is in archivelog mode but the redo logs are growing very quickly and not arhiving them off...
    Hello to all.

    If your db is in archive log mode AND the archiver process is automatically started at instance startup (more or less as others have told to you), you must check the file system in which the arch process is writing into:
    0) the filesystem and directory structure must exists
    1) there must be enough space in that FS
    2) arch can have the rights to crete files and write them into the dir

    After that you must check that your online redologs are big enough to give time to the arch process to copy a redolog meanwhile the CURRENT redolog is filled, eventually add new online redologs.

    hoping this will help.
    Best regards.
    Franco Ceotto
    SIPTI srl
    OnSite Services
    9i OCP DBA, Performance Engineer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •