Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2003
    Posts
    3

    Red face Unanswered: sqlserveragent fails

    Heeeeelp me please
    My sql server 8(sp3) runs ok, but the sql server agent don't starts.
    Is configured to start at the os startup, and I tryed to start it manually...
    In the Log Viewer of windows I can see:

    <<Error ID- 103
    Source- Sqlserveragent
    SQLServerAgent could not be started (reason: Unable to connect to server '(local)'; SQLServerAgent cannot start). >>

    Can you help me?
    thnks

  2. #2
    Join Date
    Jun 2003
    Location
    cape town, south africa
    Posts
    102
    what account is sql server / agent both running as?

    is agent configured to use windows or sql authentication when connecting to the server? does it have an account with the necessary priveleges?
    (right click on the agent in enterprise manager and check its settings)

    run @@servername and make sure server name is not null...

  3. #3
    Join Date
    Oct 2003
    Posts
    3
    thnks for your answer
    I use sql auth, with user (for exaple) "sa" "passwd", the sql superuser.

    I don't understand "run @@servername".

  4. #4
    Join Date
    Jun 2003
    Location
    cape town, south africa
    Posts
    102
    @@servername is a T-SQL command - will return the name your server responds to (ie. on a machine called Foo, the @@servername value would by default also be Foo.

    Sometimes this value is missing and can cause connectivity problems - probbably not the case here but worth checking (since you error message referes to sql as 'local', not a name (not necessarily a problem))

  5. #5
    Join Date
    Oct 2003
    Posts
    3
    sorry, how can I use it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •