Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2003
    Location
    Colombia
    Posts
    13

    Angry Unanswered: SQL Server error codes

    Hi all. I am a beginner with SQL Server, and I am getting repeatedly the 17968 error. I searched in all Microsoft sites (technet, MSDN) and did not find any information about it. The error is not in the SQL Server error list provided by Microsoft (pretty short and unexplained, by the way).
    Is there a place where I can find a list of MSSQL errors? If you can help me out with this error, please let me know. Thanks.

  2. #2
    Join Date
    Nov 2002
    Location
    Jersey
    Posts
    10,322
    You must be getting a message as well...what is it?
    Brett
    8-)

    It's a Great Day for America everybody!

    dbforums Yak CorralRadio 'Rita
    dbForums Member List
    I'm Good Once as I ever was

    The physical order of data in a database has no meaning.

  3. #3
    Join Date
    Nov 2002
    Location
    Jersey
    Posts
    10,322
    I did a google and got this...

    Code:
    418   if (( @rep_off_schema = 1 ) or ( @reptostandbyon = 1 ))
    419   begin
    420       select @after_image = 0
    421       select @mod_versionts = 1
    422       if ( logschema ( @objid , @user_tran , @after_image ,
    423                   @mod_versionts )!= 1 )
    424       begin
    425           /*
    426   			** 17968 "The built-in function logschema() failed 
    427   			** for '%1!'."
    428   			*/
    429           exec sp_getmessage 17968 , @msg output
    430           print @msg , @replicate_name
    431   
    432           rollback transaction
    433           return ( 1 )
    434       end
    Brett
    8-)

    It's a Great Day for America everybody!

    dbforums Yak CorralRadio 'Rita
    dbForums Member List
    I'm Good Once as I ever was

    The physical order of data in a database has no meaning.

  4. #4
    Join Date
    Oct 2003
    Location
    Colombia
    Posts
    13
    I searched in google too and got the same page. The logschema did not gave me any hint in solving the problem, however.
    I have been checking the server's App Log and it seems it is runnig xp_sendmail right, but taking parameters wrong. I rewrote the procedure that seems to cause the problem, but I am not still sure of this. Thank you.

  5. #5
    Join Date
    Oct 2003
    Location
    Colombia
    Posts
    13
    This is the error App Log message:

    Error: 17968, Severity: 16, State: 62
    2003-10-25 12:05:02.20 ods Error encountered while executing xp_sendmail @query..
    Operating system error 2812., Could not find stored procedure 'Bloqueos'.

    As I said before, it seems like xp_sendmail takes the subject parameter as if it were query parameter. Any comments would be appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •