Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2003
    Posts
    13

    Angry Unanswered: ASE was running......

    Successfully installed ASE 12.5 dev edition and was able to log in using isql upon installation. A reboot and now I'm getting:


    00:00000:00000:2003/10/28 15:37:54.23 kernel Using config area from primary master device.
    00:00000:00000:2003/10/28 15:37:54.32 kernel os_create_region: can't allocate 40589312 bytes
    00:00000:00000:2003/10/28 15:37:54.32 kernel kbcreate: couldn't create kernel region.
    00:00000:00000:2003/10/28 15:37:54.32 kernel kistartup: could not create shared memory

    Thoughts are greatly appreciated.

  2. #2
    Join Date
    Jan 2003
    Posts
    26

    Re: ASE was running......

    It looks like Sybase is trying to use more memory than its allowed to. What's your max shared memory segment size? If it's less than 40589312 bytes, try setting it to a little less than however much memory you have -- assuming that you have more than 40MB -- and then start Sybase. The other option is to set the amount of memory that Sybase requests to be less than your max shared memory segment size. Not sure about 12.5 but in 11.9.2 the "total memory" param in the config file specifies this.

    Hope this helps.

    Frank

    Originally posted by oracsol
    Successfully installed ASE 12.5 dev edition and was able to log in using isql upon installation. A reboot and now I'm getting:


    00:00000:00000:2003/10/28 15:37:54.23 kernel Using config area from primary master device.
    00:00000:00000:2003/10/28 15:37:54.32 kernel os_create_region: can't allocate 40589312 bytes
    00:00000:00000:2003/10/28 15:37:54.32 kernel kbcreate: couldn't create kernel region.
    00:00000:00000:2003/10/28 15:37:54.32 kernel kistartup: could not create shared memory

    Thoughts are greatly appreciated.

  3. #3
    Join Date
    Sep 2003
    Posts
    13

    Re: ASE was running......

    Thanks, looks like my shmmax setting didn't take. Reentered
    it and everything is running again.

    Originally posted by frankp
    It looks like Sybase is trying to use more memory than its allowed to. What's your max shared memory segment size? If it's less than 40589312 bytes, try setting it to a little less than however much memory you have -- assuming that you have more than 40MB -- and then start Sybase. The other option is to set the amount of memory that Sybase requests to be less than your max shared memory segment size. Not sure about 12.5 but in 11.9.2 the "total memory" param in the config file specifies this.

    Hope this helps.

    Frank

  4. #4
    Join Date
    Jan 2003
    Posts
    26

    Re: ASE was running......

    The shmmax setting gets lost on reboot so what you can do is put something like the following in your Sybase init script before the db is started:
    echo 1073741824 > /proc/sys/kernel/shmmax

    Originally posted by oracsol
    Thanks, looks like my shmmax setting didn't take. Reentered
    it and everything is running again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •