Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2003
    Posts
    2

    Unanswered: Connecti 9i from 9iDS Forms

    Hi,

    I have installed 9iDS and 9iDatabase Rel.2 on same pc. Sql* from 9iDS works without any string i.e. scott/tiger and like that FORMS connects but when I run a new form from FORM BUILDER I get ORA-12560 TNS: Protocol adaptor error.

    Why it get connected first and then shows error when I try to run compiled form?


    Abu Abdull@h

  2. #2
    Join Date
    Sep 2003
    Posts
    156

    Re: Connecti 9i from 9iDS Forms

    Originally posted by Abu Abdull@h
    Hi,

    I have installed 9iDS and 9iDatabase Rel.2 on same pc. Sql* from 9iDS works without any string i.e. scott/tiger and like that FORMS connects but when I run a new form from FORM BUILDER I get ORA-12560 TNS: Protocol adaptor error.

    Why it get connected first and then shows error when I try to run compiled form?


    Abu Abdull@h
    are they istalled in the same 'home' or in different 'homes' or directories... if so, you'll need to copy (from the DB home to the corresponding 9iDS directory) or edit your tnsnames.ora file. check your services to see if your tns listener is running...
    rgs,

    Ghostman

  3. #3
    Join Date
    Sep 2003
    Location
    The Netherlands
    Posts
    311
    hi,

    9ids and 9idatabase will be installed in different oracle_home.
    The cause of the problem would that each oracle_home has to have it's own tns config files, like tnsnames.ora.
    Several ways to solve this.

    1.Quick and Dirty: copy the tnsnames.ora and sqlnet.ora from the ORACLEHOME9iRDBMS\network\admin dir to the ORACLEHOME9iDS\network\admin dir.

    2. Clean1
    Create a new tnsnames and sqlnet using the cofig assistant.

    3. Clean2
    Create an environment setting to point to a single location for all oracle_homes as they are and will be installed. To do this create an environment variable called TNS_ADMIN and for the value, point tothe directory where the tnsnames.ora resides, without the name of the file. On windows u can do this by right clicking my computer, click properties, go to the Advanced tab, click environment variables, in the upper box create a new variable by clicking the NEW button. Name of the variable = TNS_ADMIN value= path to the tnsnames.ora file.

    Hope this helps.
    Edwin van Hattem
    OCP DBA / System analyst

  4. #4
    Join Date
    Oct 2003
    Posts
    2
    Hi evanhattem,

    Thanks, now it works fine....


    Abu Abdull@h

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •