Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2003
    Posts
    35

    Unanswered: phpmyadmin won't instal

    Hi,

    I have downloaded and extracted phpmyadmin but when i go to the file the instal icon is not recognised by winxp pro and when double clicking window asks 'what program created this file'. I have searched all the help files but no good, help

    Many thanks,

    Mark

  2. #2
    Join Date
    Oct 2003
    Location
    Chicago, IL
    Posts
    34
    There is no need for any type of installation for phpmyadmin. All you have to do is to specify the root username and password for your mysql server in the config.inc.php file that is included in the phpmyadmin folder. To use it, just go to:

    http://localhost/phpmyadmin/index.php

    Using your browser, where "/phpmyadmin/" is where you have phpmyadmin relative to the htdocs folder of your server. I hope this helps.
    Last edited by digioz; 10-30-03 at 23:03.
    DigiOz Multimedia
    http://www.digioz.com

  3. #3
    Join Date
    Sep 2003
    Posts
    35
    Hi,

    After your advice all is working ok. Just one thing, I have tried to create a connnection in Dreamweaver but it has not worked. In the site definition under 'testing server' I have the server model as 'php MYSql', the access as 'local/network', the testing server folder as 'c:\myDocs....' and the url prefix as 'http://localhost/'. Is this correct as it might be a stupid question but where is the mysql database stored?

    Many thanks for any help you can give me.

    Mark

  4. #4
    Join Date
    Oct 2003
    Location
    Chicago, IL
    Posts
    34
    Here is a brief introduction to Setting up a PHP/MySQL site definition in Dreamweaver. Let me know if it helps:

    ---------------------------------------------------------------------------------
    A successful connection to a MySQL database in Dreamweaver depends on correct Site Definition entries when defining the site. Below, is a sample PHP / MySQL Site Definition that uses a Linux PHP server running on a machine identified as mySite.myDomain.com. MySQL is running on another machine identified as mysql1.myDomain.com and Dreamweaver is running on a local workstation. FTP is used to transfer files between the workstation and the Linux web server.

    Local Info:
    Site Name: mySite
    Local Root Folder: C:\mySite\
    Remote Info:
    Access: FTP
    FTP Host: mySite.myDomain.com
    Host Directory: /htdocs/
    Login: webadmin
    Password: *********
    Testing Server:
    Server Model: PHP / MySQL
    Access: FTP
    FTP Host: mySite.myDomain.com
    Host Directory: /htdocs/
    Login: webadmin
    Password: *********
    URL Prefix: http://mySite.myDomain.com/

    Create a MySQL database connection in Dreamweaver.
    Once the MySQL user account has been set up and the site has been defined you can connect to your MySQL database in Dreamweaver. Using the above settings, here are example settings for the MySQL Connection dialog box in Dreamweaver:

    Connection Name: choose a name (e.g. connEmp)
    MySQL Server: mysql1.myDomain.com
    User Name: dbuser
    Password: myPassword
    Database: enter the name of your database or click on the Select button to choose from a list of MySQL databases running on the server.

    Note: For the MySQL Server field you must enter localhost if PHP and MySQL are running on the same machine.

    ---------------------------------------------------------------------------------















    Originally posted by ypx5269
    Hi,

    After your advice all is working ok. Just one thing, I have tried to create a connnection in Dreamweaver but it has not worked. In the site definition under 'testing server' I have the server model as 'php MYSql', the access as 'local/network', the testing server folder as 'c:\myDocs....' and the url prefix as 'http://localhost/'. Is this correct as it might be a stupid question but where is the mysql database stored?

    Many thanks for any help you can give me.

    Mark
    DigiOz Multimedia
    http://www.digioz.com

  5. #5
    Join Date
    Sep 2003
    Posts
    35
    hi,

    Still having problems connecting to Dreamweaver. Here is what I have done so far. Maybe I have missed something out. Bear in mind I am a novice at this although the same process took 5 mins in asp.

    I have apache running and can connect to the database.
    I have created a uname and password directly in mySql.
    I have changed the username and password in the config.ini.php file in all three places except the place where it says ‘If you wish to use the SQL Validator service, you should be * aware of the following:…’. I have left this as it is, hope this is correct

    Everything is in the c drive ‘C:\PHPDEV’, which in turn contains folders such as ‘mysql’, ‘phpmyadmin’, ‘private’, ‘www’ and some more.

    In Dreamweaver I did the following:

    Local info
    Site name: protechPHP2
    Local root folder: C:\Documents and Settings\My Name\My Documents\protechphp2\
    HTTP Address: http://

    No Remote info as I would just like to connect locally (at the moment)

    Testing server
    Server model: php mySql
    Access: local/network
    Testing server folder: C:\PHPDEV\www\protechPHP\ (i don’t think this is correct, but have tried lots of different combinations)
    URL Prefix: http://localhost/

    In Dremweaver I have the following:
    Connection name: connProtech
    mySql Server: localhost
    username: (same as the one in the config.inc.php file)
    password: (same as the one in the config.inc.php file)
    database: Here I click on the select button and it comes back with a message saying the possible reasons are: 1) there is no sever running on the server machine. 2) the testing server specified for this site does not map to the http://localhost/_mmServerScripts/MMHTTPDB.php URL. Verify that the URL prefix maps to the root of the site.

    I know it is not mapping ok but how can I do it. If you need any more info just say, I would appreciate if you could help with this probem.

    Mark

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •