Results 1 to 10 of 10
  1. #1
    Join Date
    Oct 2003
    Location
    Karachi
    Posts
    12

    Question ORA-01004 Default username feature not supported; logon denied

    I m using ORACLE 9i on linux 9, the oracle is running fine and authenticating users using OS authentication method by providing command "sqlplus /". But when i m going to connect through remote client it is giving the...

    error: ORA-01004 Default username feature not supported; logon denied

    Following are the parameters settings"

    # SQLNET.ORA Network Configuration File: /oracle/u01/app/oracle/product/9.2.0/n
    # Generated by Oracle configuration tools.

    NAMES.DEFAULT_DOMAIN = ssuet.edu.pk

    NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)

    # sqlnet.authentication_services = (NTS)

    # REMOTE_OS_AUTHENT = TRUE

    # SQLNET.AUTHENTICATION_SERVICES=(NTS)


    # in initSID.ora
    remote_os_authent = true
    os_authent_prefix = ""

  2. #2
    Join Date
    Sep 2003
    Location
    The Netherlands
    Posts
    311
    hi,

    decomment the line :

    # sqlnet.authentication_services = (NTS)

    to

    sqlnet.authentication_services = (NTS)

    hope this helps.
    Edwin van Hattem
    OCP DBA / System analyst

  3. #3
    Join Date
    Oct 2003
    Location
    Karachi
    Posts
    12

    Question STill the problem is same

    Hi

    Thank you for your reply.

    I've uncommented that statement but the problem occured on hosted machine (Oracle Server) and still there the problem on client as well

    Kindly help


    Jawed

    Originally posted by evanhattem
    hi,

    decomment the line :

    # sqlnet.authentication_services = (NTS)

    to

    sqlnet.authentication_services = (NTS)

    hope this helps.

  4. #4
    Join Date
    Sep 2003
    Location
    The Netherlands
    Posts
    311
    what linux do u use? Suse, redhat, debian ?

    greetz
    Edwin van Hattem
    OCP DBA / System analyst

  5. #5
    Join Date
    Oct 2003
    Location
    Karachi
    Posts
    12

    Question OS Using

    I am using Redhat Linux 9


    Regards

    Jawed


    Originally posted by evanhattem
    what linux do u use? Suse, redhat, debian ?

    greetz

  6. #6
    Join Date
    Oct 2003
    Location
    Karachi
    Posts
    12

    Question OS Using

    I am using Redhat Linux 9


    Regards

    Jawed


    Originally posted by evanhattem
    what linux do u use? Suse, redhat, debian ?

    greetz

  7. #7
    Join Date
    Oct 2003
    Location
    Karachi
    Posts
    12

    OS Using

    Hi

    I m using Redhat linux 9.0


    Regards

    Jawed


    Originally posted by evanhattem
    what linux do u use? Suse, redhat, debian ?

    greetz

  8. #8
    Join Date
    Oct 2003
    Posts
    26

    Re: OS Using

    What is the value of the init parameter REMOTE_LOGIN_PASSWORDFILE ?

    If it is set to NONE, set to EXCLUSIVE and then try to connect from the remote client

    HTH
    Arvind

  9. #9
    Join Date
    Oct 2003
    Location
    Karachi
    Posts
    12

    Re: OS Using

    Parameter remote_login_passwordfile already set to exclusive in init file but it is not working why?


    Jawed


    Originally posted by arvindl
    What is the value of the init parameter REMOTE_LOGIN_PASSWORDFILE ?

    If it is set to NONE, set to EXCLUSIVE and then try to connect from the remote client

    HTH
    Arvind

  10. #10
    Join Date
    Sep 2003
    Location
    The Netherlands
    Posts
    311
    hi,

    did u bounce the database ?

    greetz
    Edwin van Hattem
    OCP DBA / System analyst

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •