Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2003
    Location
    VA
    Posts
    8

    Unanswered: Trouble with weblogic connecting to oracle

    I've set up weblogic 5.1 on a Win 2000 machine. It needs to connect to Oracle on a Sun Machine running Solaris 8. I'm basically mimicking a set up that I've done before between a Win NT machine and Oracle on a Sun machine running Solaris 8. I'm puzzled by this error:

    Delaying 1 seconds before making a OraclePool pool connection.
    +++ WebLogic Native Layer for OCI 8.x (BETA-2)


    ---------- LOGIN ERROR CODE: 24327
    Fri Oct 31 04:19:34 EST 2003:<I> <JDBC Pool> Sleeping in createResource()
    Fri Oct 31 04:19:35 EST 2003:<E> <JDBC Pool> Failed to create connection pool "O
    raclePool"
    weblogic.common.ResourceException: weblogic.common.ResourceException:
    Could not create pool connection. The DBMS driver exception was:
    java.sql.SQLException: Error while trying to retrieve text for error ORA-24327 -
    (appserver/********@jgora.foo.com)
    at weblogic.db.oci.OciConnection.getLDAException(OciC onnection.java:143)

    at weblogic.jdbcbase.oci.Driver.connect(Driver.java:1 57)
    at weblogic.jdbc.common.internal.ConnectionEnvFactory .makeConnection(Con
    nectionEnvFactory.java:146)
    at weblogic.jdbc.common.internal.ConnectionEnvFactory .createResource(Con
    nectionEnvFactory.java:108)
    at weblogic.common.internal.ResourceAllocator.makeRes ources(ResourceAllo
    cator.java:771)
    at weblogic.common.internal.ResourceAllocator.<init>( ResourceAllocator.j
    ava:416)
    at weblogic.jdbc.common.internal.ConnectionPool.start up(ConnectionPool.j
    ava:330)
    at weblogic.jdbc.common.internal.JdbcInfo.initPools(J dbcInfo.java:117)
    at weblogic.jdbc.common.internal.JdbcInfo.startup(Jdb cInfo.java:200)
    at weblogic.jdbc.common.internal.JdbcStartup.main(Jdb cStartup.java:11)
    at java.lang.reflect.Method.invoke(Native Method)
    at weblogic.t3.srvr.StartupThread.runMain(StartupThre ad.java:219)
    at weblogic.t3.srvr.StartupThread.doWork(StartupThrea d.java:109)
    at weblogic.t3.srvr.PropertyExecuteThread.run(Propert yExecuteThread.java
    :62)

    at weblogic.jdbc.common.internal.ConnectionEnvFactory .makeConnection(Con
    nectionEnvFactory.java:154)
    at weblogic.jdbc.common.internal.ConnectionEnvFactory .createResource(Con
    nectionEnvFactory.java:108)
    at weblogic.common.internal.ResourceAllocator.makeRes ources(ResourceAllo
    cator.java:771)
    at weblogic.common.internal.ResourceAllocator.<init>( ResourceAllocator.j
    ava:416)
    at weblogic.jdbc.common.internal.ConnectionPool.start up(ConnectionPool.j
    ava:330)
    at weblogic.jdbc.common.internal.JdbcInfo.initPools(J dbcInfo.java:117)
    at weblogic.jdbc.common.internal.JdbcInfo.startup(Jdb cInfo.java:200)
    at weblogic.jdbc.common.internal.JdbcStartup.main(Jdb cStartup.java:11)
    at java.lang.reflect.Method.invoke(Native Method)
    at weblogic.t3.srvr.StartupThread.runMain(StartupThre ad.java:219)
    at weblogic.t3.srvr.StartupThread.doWork(StartupThrea d.java:109)
    at weblogic.t3.srvr.PropertyExecuteThread.run(Propert yExecuteThread.java
    :62)

    at weblogic.jdbc.common.internal.ConnectionEnvFactory .createResource(Con
    nectionEnvFactory.java:124)
    at weblogic.common.internal.ResourceAllocator.makeRes ources(ResourceAllo
    cator.java:771)
    at weblogic.common.internal.ResourceAllocator.<init>( ResourceAllocator.j
    ava:416)
    at weblogic.jdbc.common.internal.ConnectionPool.start up(ConnectionPool.j
    ava:330)
    at weblogic.jdbc.common.internal.JdbcInfo.initPools(J dbcInfo.java:117)
    at weblogic.jdbc.common.internal.JdbcInfo.startup(Jdb cInfo.java:200)
    at weblogic.jdbc.common.internal.JdbcStartup.main(Jdb cStartup.java:11)
    at java.lang.reflect.Method.invoke(Native Method)
    at weblogic.t3.srvr.StartupThread.runMain(StartupThre ad.java:219)
    at weblogic.t3.srvr.StartupThread.doWork(StartupThrea d.java:109)
    at weblogic.t3.srvr.PropertyExecuteThread.run(Propert yExecuteThread.java
    :62)

    Any thoughts or help would be much appreciated.

  2. #2
    Join Date
    May 2003
    Location
    France
    Posts
    112

    Re: Trouble with weblogic connecting to oracle

    Hi,

    what is oracle version ?
    Have you set correctly ORACLE_HOME variable in Weblogic ?

    rgds.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •