Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2003
    Location
    Köln, Germany
    Posts
    6

    Unhappy Unanswered: JDBC and Informix 7.12

    Hello!

    I can't connect to a Informix DB V7.12 over JDBC from a IBM AIX, but it works from a WinNT-PC and a linux-maschine.
    On every maschine is the same JDBC-driver, but on aix i get following error:

    SQLException: Server does not support GLS variables DB_LOCALE, CLIENT_LOCALE or GL_DATE.
    SQLState: IX000
    Message: Server does not support GLS variables DB_LOCALE, CLIENT_LOCALE or GL_DATE.
    Vendor: -79789

    but no one of these variables are set!

    can everybody help me?

    BR
    Uwe Terborg

  2. #2
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780

    Re: JDBC and Informix 7.12

    Originally posted by frodo123
    Hello!

    I can't connect to a Informix DB V7.12 over JDBC from a IBM AIX, but it works from a WinNT-PC and a linux-maschine.
    On every maschine is the same JDBC-driver, but on aix i get following error:

    SQLException: Server does not support GLS variables DB_LOCALE, CLIENT_LOCALE or GL_DATE.
    SQLState: IX000
    Message: Server does not support GLS variables DB_LOCALE, CLIENT_LOCALE or GL_DATE.
    Vendor: -79789

    but no one of these variables are set!

    can everybody help me?

    BR
    Uwe Terborg
    Hi,

    Test on NT, run setnet32 and look the variables CLIENT_LOCAL and DB_LOCAL.
    In the database server, test the environment variable or user variables.
    By default the language of database is "en_US.819", run "SELECT * from systables where tabid = 90"
    And test the lenguage of operating system with command "locale".


    Gustavo.

  3. #3
    Join Date
    Oct 2003
    Location
    Köln, Germany
    Posts
    6
    Hello!

    In tne db there is no table with the tabid=90.
    On my NT-PC there is no setnet32, because i installed only the jdbc-driver.

    BR
    Uwe Terborg

  4. #4
    Join Date
    Aug 2003
    Location
    Argentina
    Posts
    780
    Originally posted by frodo123
    Hello!

    In tne db there is no table with the tabid=90.
    On my NT-PC there is no setnet32, because i installed only the jdbc-driver.

    BR
    Uwe Terborg
    Hi,

    OK, You need Informix Client-SDK, version 2.80 or 2.81 or JDBC provided by Informix.

    Gustavo.

  5. #5
    Join Date
    Oct 2003
    Location
    Köln, Germany
    Posts
    6

    Talking

    Hi!

    i resolved the problem! the solution is to set following variables:

    LANG + LC_CTYPE.

    Now it works!

    Thanks!

    BR
    Uwe Terborg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •