Results 1 to 8 of 8
  1. #1
    Join Date
    Feb 2002
    Posts
    43

    Unanswered: skip grant tables

    Whenever I start the mysqld deamon I have to issue the --skip-grant-tables options so that I can make a connection to the database. Does anyone know why this might occur and how to fix it.

  2. #2
    Join Date
    Sep 2002
    Location
    Montreal, Canada
    Posts
    224
    Provided Answers: 1

    Re: skip grant tables

    Originally posted by cmptrguru7
    Whenever I start the mysqld deamon I have to issue the --skip-grant-tables options so that I can make a connection to the database. Does anyone know why this might occur and how to fix it.
    What user are you using to connect?
    Looks like you don't have an access privilege to the database you're trying to connect to.

    See:
    http://www.mysql.com/doc/en/Access_denied.html

  3. #3
    Join Date
    Feb 2002
    Posts
    43

    Re: skip grant tables

    Originally posted by bstjean
    What user are you using to connect?
    Looks like you don't have an access privilege to the database you're trying to connect to.

    See:
    http://www.mysql.com/doc/en/Access_denied.html
    I have created a new user and given them full access to the database. I can connect with this user or any other user if I start the deamon with the --skip-grant-tables option, but if I start it normally then I am unable to connect.

  4. #4
    Join Date
    Sep 2002
    Location
    Montreal, Canada
    Posts
    224
    Provided Answers: 1

    Re: skip grant tables

    Originally posted by cmptrguru7
    I have created a new user and given them full access to the database. I can connect with this user or any other user if I start the deamon with the --skip-grant-tables option, but if I start it normally then I am unable to connect.
    Did you flush privileges?

    What is the error message?

    What command do you use to start the daemon and what command do you use to connect with the client?

  5. #5
    Join Date
    Feb 2002
    Posts
    43

    Re: skip grant tables

    Originally posted by bstjean
    Did you flush privileges?

    What is the error message?

    What command do you use to start the daemon and what command do you use to connect with the client?
    Yes I deleted all users and privileges and reinstalled them as if the database were fist installed. I then created a database and a user with full permissions on the database. I can connect locally always, but if I do not issue the --skip-grant-tables option then I am unable to connect remotely. I start the deamon: mysqld &.

    The error message is I get if I do not use --skip-grant-tables is:
    Access denied for user: 'user@server' (Using password: YES)

    I have checked all passwords to make sure they were correct.

  6. #6
    Join Date
    Sep 2002
    Location
    Montreal, Canada
    Posts
    224
    Provided Answers: 1

    Re: skip grant tables

    Originally posted by cmptrguru7
    Yes I deleted all users and privileges and reinstalled them as if the database were fist installed. I then created a database and a user with full permissions on the database. I can connect locally always, but if I do not issue the --skip-grant-tables option then I am unable to connect remotely. I start the deamon: mysqld &.

    The error message is I get if I do not use --skip-grant-tables is:
    Access denied for user: 'user@server' (Using password: YES)

    I have checked all passwords to make sure they were correct.

    Try:

    mysqld --user=yourusername --password=yourpassword

  7. #7
    Join Date
    Feb 2002
    Posts
    43
    That works to start the deamon and actually starting the deamon works just fine, but that does not solve my problem when trying to log into the database using something like php or access. If I login to my linux server and excute mysql at the command prompt I can login no problem, but when try to connect outside I get the error, but only of I start the deamon without the --skip-grant-tables option. I know this is complex and I thank you for all your help.

  8. #8
    Join Date
    Jan 2004
    Posts
    1
    Try starting mysql using the options --skip-grant-tables and --log and check the log file to see how your application is connecting to mysql. For example, it is possible that your application is connecting in using

    myuser@myhostname

    rather than

    myuser@localhost

    in this case you need to create your mysql user like

    mysql> grant all privileges on *.* to myuser@myhostname identified by 'mypassword' with grant option;

    in addition to

    mysql> grant all privileges on *.* to myuser@localhost identified by 'mypassword' with grant option;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •