I am having probems connecting to a local mysql database in Dreamwever MX.

Here is what I have done so far. Maybe I have missed something out as I am new to Dreamweaver and mysql.

I have apache running and can connect to the mysql database through phpmyadmin.
I have created a uname and password directly in mySql
I have changed the username and password in the config.ini.php file in all three places except the place where it says ‘If you wish to use the SQL Validator service, you should be * aware of the following:…’. I have left this as it is, hope this is correct.

Everything is in my c drive ‘C:\PHPDEV’, which in turn contains folders such as ‘mysql’, ‘phpmyadmin’, ‘private’, ‘www’ and some more.

In Dreamweaver I did the following:

Local info
Site name: protechPHP2
Local root folder: C:\Documents and Settings\My Name\My Documents\protechphp2\
HTTP Address: http:// (i have left the default)

No Remote info as I would just like to connect locally (at the moment)

Testing server
Server model: php mySql
Access: local/network
Testing server folder: C:\PHPDEV\www\protechPHP\ (i don’t think this is correct, help!!!!)
URL Prefix: http://localhost/

In Dremweaver I have the following:
Connection name: connProtech
mySql Server: localhost
username: (same as the one in the config.inc.php file)
password: (same as the one in the config.inc.php file)
database: Here I click on the select button and it comes back with a message saying the possible reasons are: 1) there is no sever running on the server machine. 2) the testing server specified for this site does not map to the http://localhost/_mmServerScripts/MMHTTPDB.php URL. Verify that the URL prefix maps to the root of the site.

I know it is not mapping ok but how can I do it? If you need any more info just say, I would appreciate if you could help with this problem.