Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2003

    Question Unanswered: SQL Server DTS and Teradata

    I am having a problem losing my decimal precision after importing data from Teradata using DTS.

    I am using an ODBC connection to Teradata specifying the input as a query. "Select * from flm.VEL_CR_HDR_HIST"

    The column on Teradata is defined as
    type decimal, length 4, format -----.999 & nullable

    The column is defined by DTS import on SQL server as
    numeric with precision 7 scale 3.

    The input data viewed thru queryman, WINDDI and even MS ACCESS using ODBC shows 19.07

    However, when I look at the DTS test results for the column it shows 19.000.

    When I execute the import and view the table it shows 19.000

    I have tried changing the DTS "select" to use a cast statement as decimal(7,3) but it didn't make any difference.

    Can anyone help me? Is there some parameter in SQL server or Teradata that is causing this truncation of the decimal precision?


  2. #2
    Join Date
    Nov 2002
    Sounds like the tereadata definition is anything getting through untruncated?

    Teradata is defined as length 4? what about it's precision?

    What's the actual TD code to build the column?

    It's a Great Day for America everybody!

    dbforums Yak CorralRadio 'Rita
    dbForums Member List
    I'm Good Once as I ever was

    The physical order of data in a database has no meaning.

  3. #3
    Join Date
    Sep 2003
    All Columns on any Teradata table with decimals are truncated when they are returned to SQL server using DTS.

    But...... When I use MS Access against a view of a teradata table using the same ODBC connection the decimals are not truncated. (I used a view because MS Access was only letting me link to a view via the ODBC connection)

    I tried DTS using the same view but I got the same results (decimals were truncated).

    Since I could look at the data in MS Access using the same ODBC connection, I would think that excludes Teradata & the ODBC connection from being the culprit. So I inclined to believe it's related to DTS when accessing Teradata. I do not have the decimal truncation problem using DTS and DB2.

    The TD table was originally created using Multiload the column in question was defined

    Looking at the table via WINDDI shows the table defintion as
    type decimal, length 4, format -----.999 & nullable

  4. #4
    Join Date
    Sep 2003
    Thanks for you help. I received a post from the Teradata ListServ.

    Subject: Re: [TDATA:] Using SQL server DTS and Teradata

    It's an incompatibility between MSDASQL provider and Teradata ODBC
    Upgrade to the latest version of the Teradata ODBC driver or switch to
    using Teradata native OLE DB provider.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts