Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2003

    Unanswered: Procedure - SQL0440N

    DB2 Ver 8.1 Fixpack 3.
    O/S AIX 5L

    I am facing strange problems on the DB2 Procedures. This procedures where working fine from long time, but all of
    sudden the procedures are not able to get executed.

    I tried to copy those in the sample folder and tried compiling and executing them but
    When I compile the procedure it gets compiled and there are no errors or warnings. But when I try to execute
    by passing parameters it gives me error as follows :

    SQL0440N No authorized routine named "UPDATE_SALARY_IF" of type "PROCEDURE"
    having compatible arguments was found. SQLSTATE=42884

    Can anybody help me on this ..

    Many Thanks.

  2. #2
    Join Date
    Jan 2003
    Provided Answers: 5
    Did you GRANT execute rights to the procedure?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts