Results 1 to 1 of 1
  1. #1
    Join Date
    Nov 2003
    Posts
    1

    Red face Unanswered: ASE 12.5 truncating images to 16kb

    I have converted to ASE 12.5 and my application using JDBC to store
    image data, the image data is being truncated to 16kb. When the
    application is run on 11.5 the data is not truncated. I have tried the following:

    I am trying to insert a pdf and html document in Sybase image column using java. I am inserting data using setBytes. Sybase 12.5 truncates the data to less than 16 KB without giving any errors/warnings. I was able to save more than 1 MB file in 11.5.

    Currently I am using jConnect 4.2, I have tried using jConnect 5.2. I also changed setBytes to setBinaryStream but no luck.

    Setting SET TEXTSIZE before inserting did not help either

    Does anybody have any idea what is going on here? Is this a jConnect issue or a Sybase issue? Please help as I am completely lost here.

    Thanks.
    Last edited by mcchillyo; 11-11-03 at 13:46.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •