Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2003
    Posts
    15

    Unanswered: scheduling stored procedure

    Hi,

    I am trying to schedule a stored procedure using SQL server Agent and i get the following error:
    DELETE failed because the following SET options have incorrect settings: 'ARITHABORT'. [SQLSTATE 42000]

    please help

    regards,
    hiren

  2. #2
    Join Date
    Oct 2003
    Location
    Ireland
    Posts
    54
    I found this in SQL Books Online.

    Is it appropriate, ie do you have computed columns etc ?

    If SET ARITHABORT is OFF, CREATE, UPDATE, INSERT, and DELETE statements on tables with indexes on computed columns or indexed views will fail.

  3. #3
    Join Date
    Nov 2002
    Location
    Jersey
    Posts
    10,322
    Well what's it set to?

    Do you have a trigger on the table?
    Brett
    8-)

    It's a Great Day for America everybody!

    dbforums Yak CorralRadio 'Rita
    dbForums Member List
    I'm Good Once as I ever was

    The physical order of data in a database has no meaning.

  4. #4
    Join Date
    Nov 2003
    Posts
    15
    Hi,

    No there are no triggers. I have found the solution.
    The connection related setting for the SQL server needs to be checked for the same. I performed the following steps....
    1. In enterprise manager, right clicked on SQL Server i was accessing.
    2. Selected properties->Connections.
    3. Under 'default connection option', selected 'Arithmetic abort'
    4. Clicked OK and restarted the server.

    Thanks and regards,
    henry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •