Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2003

    Angry Unanswered: postgresql-7.3.4 install woes!


    I am having a few problems installing postgresql-7.3.4:

    When I run:
    [postgres@postgresql-7.3.4]$./configure --with-includes=/usr/local/apache/include/ --with-libraries=/usr/local/apache/lib --with-tcl --with-tclconfig=/usr/local/apache/lib --without-tk
    configure: creating ./config.status
    config.status: creating GNUmakefile
    config.status: creating src/
    config.status: creating src/include/pg_config.h
    config.status: src/include/pg_config.h is unchanged
    config.status: linking ./src/backend/port/tas/dummy.s to src/backend/port/tas.s
    config.status: linking ./src/backend/port/dynloader/freebsd.c to src/backend/port/dynloader.c
    config.status: linking ./src/backend/port/sysv_sema.c to src/backend/port/pg_sema.c
    config.status: linking ./src/backend/port/sysv_shmem.c to src/backend/port/pg_shmem.c
    config.status: linking ./src/backend/port/dynloader/freebsd.h to src/include/dynloader.h
    config.status: linking ./src/include/port/freebsd.h to src/include/pg_config_os.h
    config.status: linking ./src/makefiles/Makefile.freebsd to src/Makefile.port

    it seems to finish fine...

    but then when I run gmake
    gmake[4]: Leaving directory `/usr/home/shane/pkgs/postgresql-7.3.4/src/interfaces/libpgtcl'
    gcc -pipe -Wall -Wmissing-prototypes -Wmissing-declarations pgtclAppInit.o -L../../../src/interfaces/libpgtcl -lpgtcl -L../../../src/interfaces/libpq -lpq -L/usr/local/apache/lib -ltcl8.3 -lm -L/usr/local/apache/lib -R/usr/local/pgsql/lib -lz -lreadline -lcrypt -lcompat -lm -lutil -o pgtclsh
    /usr/libexec/elf/ld: cannot find -ltcl8.3
    gmake[3]: *** [pgtclsh] Error 1
    gmake[3]: Leaving directory `/usr/home/shane/pkgs/postgresql-7.3.4/src/bin/pgtclsh'
    gmake[2]: *** [all] Error 2
    gmake[2]: Leaving directory `/usr/home/shane/pkgs/postgresql-7.3.4/src/bin'
    gmake[1]: *** [all] Error 2
    gmake[1]: Leaving directory `/usr/home/shane/pkgs/postgresql-7.3.4/src'
    gmake: *** [all] Error 2

    tcl8.3 is installed and there is a folder in the /usr/local/apache/lib directory.

    Has anybody got any ideas???


  2. #2
    Join Date
    Nov 2003

    ./configure --with-includes=/usr/local/apache/include --with-libraries=/usr/local/apache/lib --with-tcl --with-tclconfig=/usr/local/lib/tcl8.2 --without-tk

    and it worked fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts