Results 1 to 8 of 8
  1. #1
    Join Date
    Nov 2003
    Posts
    5

    Question Unanswered: TNS issue with upgrade

    Hello all ---

    i have a fully working Oracle database under version 9.2.0.1

    when i run the OUI and upgrade it to 9.2.0.4 my listener no longer connects to the database.

    under 9.2.0.1 the listener service starts, although with

    TNS-12541: TNS:no listener
    TNS-12560: TNSrotocol adapter error
    TNS-00511: No listener
    32-bit Windows Error: 61: Unknown error

    and i can then tnsping and the database works with my application.

    when i upgrade to 9.2.0.4, the service starts, i get the same error, but i can not tnsping.

    i can provide as much detail as needed -- please let me know what you all think about this. thanks in advance,

    tired of ghosting

    d

  2. #2
    Join Date
    Nov 2003
    Location
    Bangalore, INDIA
    Posts
    333

    Thumbs up

    Hi,

    TNS-12541: TNS:no listener
    TNS-12560: TNSrotocol adapter error
    TNS-00511: No listener

    This problem is mostly due to Wrong LOGIN NAME & PASSWORD or Wrong entries in tnsnames.ora files. Check with it.
    SATHISH .

  3. #3
    Join Date
    Nov 2003
    Posts
    5

    TNS error

    thank you for your reply --

    the problem is that i get the error in both cases (i believe my tnsnames and sqlnet files are correct) but in one case the listener works fine and in the other it does not...

    thanks,

    d

  4. #4
    Join Date
    Nov 2003
    Posts
    5

    TNS error

    i can ping the database when i have the older version installed.
    the tnsnames, sqlnet, and listener files do not change with the upgrade, but when i try to ping the database after the upgrade i get "no listener" error even if i have started it with "lsnrctl start" or in "services"...

    very confused... any suggestions are very welcome. thank you,

    d

  5. #5
    Join Date
    Jul 2003
    Location
    Peoria AZ
    Posts
    15

    Re: TNS error

    Check your listener.ora - I just had an very similar experience going from 8.1.7.4 to 9.2.0.4 (Unix) - turns out there was an extra ) in the file ... how it worked in 8i is anybody's guess .... hope this helps ...

  6. #6
    Join Date
    Nov 2003
    Posts
    5

    TNS woes

    here are my sqlnet, tnsnames, and listener files. "avera" is the name of my application and "whitepass1" is the name of the machine.

    # SQLNET.ORA Network Configuration File: C:\Avera\oracle\ora92\NETWORK\ADMIN\sqlnet.ora
    # Generated by Oracle configuration tools.

    NAMES.DEFAULT_DOMAIN = avera
    SQLNET.AUTHENTICATION_SERVICES= (NTS)
    NAMES.DIRECTORY_PATH= (TNSNAMES)

    ______________________________________

    # TNSNAMES.ORA Network Configuration File: C:\Avera\oracle\ora92\network\admin\tnsnames.ora
    # Generated by Oracle configuration tools.

    WHITEPAS.AVERA =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = whitepass1)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVER = DEDICATED)
    (SERVICE_NAME = whitepas.avera)
    )
    )

    INST1_HTTP.WHITEPASS.COM =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = WHITEPASS1)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVER = SHARED)
    (SERVICE_NAME = MODOSE)
    (PRESENTATION = http://HRService)
    )
    )

    _____________________________________

    # LISTENER.ORA Network Configuration File: C:\Avera\oracle\ora92\network\admin\listener.ora
    # Generated by Oracle configuration tools.

    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = whitepass1)(PORT = 1521))
    )
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
    )
    )
    )

    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = C:\Avera\oracle\ora92)
    (PROGRAM = extproc)
    )
    (SID_DESC =
    (GLOBAL_DBNAME = whitepas.avera)
    (ORACLE_HOME = C:\Avera\oracle\ora92)
    (SID_NAME = whitepas)
    )
    )




    any help is greatly appreciated -- even if you make fun of my blundering. thanks,

    d

  7. #7
    Join Date
    Nov 2003
    Location
    Bangalore, INDIA
    Posts
    333

    Thumbs up Re: TNS woes

    Hi,

    Is the SID_NAME which Ur using is the right one? U better check with the SID_NAME.
    SATHISH .

  8. #8
    Join Date
    Nov 2003
    Posts
    5

    everything's good

    pulling my hair out for a week (this isn't my machine) -- turns out "zone alarm" is installed and it wouldn't accept the upgraded version of the listener because it has a different name (version). so just took it out of the list of programs to restrict and everything works great. whew.. thanks,


    d

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •