Results 1 to 6 of 6
  1. #1
    Join Date
    Nov 2003
    Posts
    3

    Unanswered: IIS and connection to my database

    Hi,
    I am trying to use IIS (local) on my pc to run an ASP site. Without a connection to the database, everything works fine, but when i include my db open and dbclose i get this error message:
    Serverobject, ASP 0177 (0x8007007E)
    8007007e ???

    My connection is like this: Set Conn = Server.CreateObject("ADODB.Connection")
    conn.Open "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=" & Server.MapPath("../database/mydatabase.mdb")

    At my Host everything works perfect.

    Any suggestions ?

    Thank you in advance

  2. #2
    Join Date
    Feb 2002
    Posts
    2,232
    Is ado installed on the iis machine ?

  3. #3
    Join Date
    Nov 2003
    Posts
    3
    Thank you for your reply - it may be the problem. I don´t know wher to look if it is ?
    I am using Windows XP Proffesionel, IIS 5.1

    Kind regards

  4. #4
    Join Date
    Feb 2002
    Posts
    2,232
    Download the mdac componenet checker from ms web site - also, update your mdac is there is a more current version.

    Here is a link to several items that should be helpful - including the component checker:

    link

  5. #5
    Join Date
    Nov 2003
    Posts
    3
    Hi again,

    Thank you very much for your help - I downloaded the MDAC and that did it. :-) Everything works now.

    Have a nice day.

  6. #6
    Join Date
    Feb 2002
    Posts
    2,232
    Good to know.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •